TestProject Forum
Powered by leading experts in the test automation community

Whats does "Step skipped" in a Report mean?


I’m using Test1 as a Step in another Test2. When I run the individual Test1 it runs successfully, but when I use it as Step in Test2 it fails. And the result Report shows some steps of Test1 as “Step skipped”. What could be the problem here?


Hello and thanks for reaching out.

Can you please tell us what agent version you are using and send us your logs?
You can go to the Agents tab and download them from there:

Try to delete test2, remove the actions that call it from test1, re-create test2 and place the actions that call it in test1 again.

Regardless, please contact us in chat to keep troubleshooting this.

Hi David, thanks for your reply!

I don’t see the option of downloading logs, maybe it’s available in the newer version. I have a slightly older version, will try to install the latest one.

Will also try to follow the other steps you have given and let you know.


That option is available for your local agent.
You should be able to get the logs that way from the same machine where the agent is installed and running.
If that is the same machine the agent is running from, you can also find the logs at %appdata%->TestProject->Agent->logs

Yeah got it. Sorry I’m being a noob here, but I’m unable to attach the logs, it only allows to attach/upload images. Is there anywhere else that I can send them?

No problem, you can always attach a shareable drive link.

Check link for the logs-logs

Thank you, we will look into this.
Please try updating to latest agent version (0.62) and seeing if the issue persist.

Hi Amit!

I want you to please update your agent to version 0.62.

ONLY If the issue still happen after you’ve updated, please take the contents of the attached .rar file and copy them into your Agent’s Installation folder.
Once you’ve done that, shutdown your running agent and start it again.

Please do tell me if the issue has been fixed and if it has what helped.


Hi Tzah,

I updated to the latest version of Agent 0.62.3 but the issue did not resolve. Then I used the contents of your .rar file, restarted the agent and it worked! What magic was that?


Glad to hear i could help!

I gave you an Agent version with a beta fix that hasn’t been tested fully by our QA.
It will get tested and will be included in the next major release (0.63)
For now, please don’t update your Agent to avoid this from happening again.

1 Like

Good afternoon! I have the same problem
I use sending a GET request and use the response from the server in another step

In the logs:
Failed to parameterize, parsing to JSON failed: com.google.gson.JsonSyntaxException: com.google.gson.stream.MalformedJsonException: Unterminated object at line 12 column 380 path $ .jsonString

Json that comes from my server:

I see “Step skipped” in the report

Hello @amit.paunikar and @tihonina.
We have released a new version of the agent , version 0.62.10 that fixed that issue.
Feel free to reach out if the issue persists.

Best Regards, Ran.