TestProject Forum

Unable to Start Recorder [SOLVED]

After the update from yesterday (2021-08-16T05:00:00Z) I can no longer start the web recorder for both new tests and for existing tests. You can still open existing tests to modify; When you hit the record button, the “System Under Test” would open as expected however, you will not get the recorder window. All the UI elements are also unclickable as well. In the DevConsole I am seeing a lot of unchecked runtime.lastError: Could not establish connection. Receiving end does not exist. errors

1 Like

Hi,
First please try the following:
Open Developer Tools ( F12 or Cmd+Opt+i on macOS)
And click right click on refresh → choose Empty Cache and Hard Reload and try again.

image

In case that doesn’t work please contact us on our support chat:

image

With the following information:

  1. Console logs
    In order to retrieve the Console Logs, please perform the following points:
  • Open developer tools using F12 on the keyboard.

  • Navigate to the Console tab

  • Perform your desired action (Make sure the error you encountered happened)

  • Right-click on one of the table rows

  • Click “Save As”

  1. HAR file

Please open Developer Tools ( F12 or Cmd+Opt+i on macOS) and witch to the Network Tab.

A. Check Disable cache checkbox. and refresh the Page ( Ctrl+F5 or Cmd+R on macOS)
B. Save HAR file

Send the file here.

  1. Agent logs

Awesome! That fixed it!

Great,
Happy to hear!