TestProject Forum

Unable to click on Objects inside APP

Hello.
I’m new to the test-project framework and it had lots of capabilities to use :star_struck:

I’m now trying to automate an APP in Android mobile and inside the APP I’m trying to click on some buttons. The problem here I’m facing is that - even though I have added the steps inside the test with exact Xpaths which had unique Xpaths, It is showing that button/Object at a different place(somewhere below the actual button/object), and it is failing to click on that button/object and the Test is failing.

Can someone help me solve this issue if I have anything missing while the configuration of the test or something!

I have attached a screenshot which is pointing the create button below the actual button(The rectangle box).


Thank you.

Hello @srianoop.d,
Can you try using this action with the exact input values:

If the exact numbers don’t work(Horizontal and Vertical) try to play with them, depending on the location of the button.

Let me know if that helped you.

Hello @artem.kuznetsov
Sorry for the late response.
I have tried this Element Action by setting up Horizontal and Vertical percentages, But it didnt work. :confused: :confused:
I have tried different combinations of those percentages but I didn’t have any luck.

Hello @srianoop.d,

Is there any other element, that you might click on, near that element that you took a screenshot of?

Hello @artem.kuznetsov
image

Yep below the create button, there is a cross button at the bottom left that closes the APP When I try clicking on create button it is closing the APP as it is not pointing at the Create button exactly.

Hi @srianoop.d,

Can we have a zoom call to resolve this?
Please reach out to us to:
support@testproject.io

Or in the support chat.

Hello @artem.kuznetsov

Yeah, I will reach out to you over mail.

Thanks for the help :relaxed: :relaxed: :relaxed: