TestProject Forum
Powered by leading experts in the test automation community

Unable to click any element


I’m trying to automate my iOS app. Ive setup everything (correctly hopefully) and can run my app through the script recorder. The problem is that once my app is up and running, I can’t do anything through the recorder. If I click on anything, the step does get added to my test but the actual click action doesn’t get performed in the recorder (Or on my connected device). I have previously used the same approach for my android app and it worked perfectly (I could see the action I perform on the recorder, get reflected on my device). What could be wrong here?


Try restarting your iOS device and avoid doing anything manually on the device.
Sometimes manual actions, such as navigating home to springboard, cause the iOS automation driver to hang.

Also, please try a different application, just to understand if this is a specific app issue.

Feel free to submit a support ticket, and our support team will be happy to meet you and assist.

I’ve restarted my device multiple times and tried, but to no avail. Also, I’ve tried the calendar app just now and still facing the same issue. Ill get in touch with the support team :slight_smile: