TestProject Forum

TP won't run through virtual agent (BrowserStack) -working prior

For some reason this morning I cannot get any tests to run through virtual Agent using browserStack.

It just keeps saying initializing and then nothing. It never actually starts the test. Not sure if this is something on TP side or an issue with BrowserStack.


Hello @marcel.bauer, and thanks for reaching out.

Do the same tests run on the local agent instead of the virtual agent?
If they do not as well, please check that the devices you are attempting to run on belong to your BrowserStack account plan and that you have automation minutes left.

If everything seems in order and the tests do not run on the local agent as well, please send the agent logs to support@testproject.io .

If the tests do not run strictly on the virtual agent, please let me know some accurate timestamps for the executions so we can get their logs from our end.

I double checked this by running a test locally = worked fine

Ran the same test but chose virtual agent>browserStack>Chrome = initializing then never runs.

I tried closing all chrome browsers, and reopening TP, also logged out and back into BrowserStack.

Here is a screenshot of my BS account

how do I get an accurate timestamp? 9:39am (PST) is when I tried a virtual test and 9:23am PST is a local run.

@marcel.bauer Is this behavior consistent with any test you execute on BrowserStack or are you noticing this on a few specific tests/jobs?

Do these tests eventually start execution? How long have has the agent been initializing?

Yes any test, seems the virtual agent never starts, it initializes for 2-3 min then goes away and say No tests or jobs are running at the moment

@marcel.bauer Thank you for the details, we will check out the issue.

I really appreciate it, David, please let me know if you need any other info from me.

Side note, I tried disabling BS in “Integrations” TAB and re-enabling, needed to re-add Virtual agent to my JOB, and then tried kicking off the tests again, and still the same result, tests never actually start running.

Not sure if that helps but just wanted to give you that info.

Any detail helps, we appreciate it.

We’ll let you know if we need any additional information.

1 Like

Hello @marcel.bauer
The issue has been resolved, you can try to run the test again on your Virtual Agent.

Please let us know if you have any further issues.

Hello @ran.tzur

I can see that they now run, as I get results through email and on slack. Also, I can see the tests running on BrowserStack side. One odd thing is in the “Monitor” tab it still appears the same, “initializing” then “No tests or jobs are running at the moment.” even though tests actually seem to be running. Just wanted to make sure that was on your radar and you are aware. Thank you for getting this back up and running.

We will check that, thank you.

1 Like

@ran.tzur @david.goichman seems this issue has crept up again. Having the exact same issue. This is extremely bad as today is deploy day and really needs these tests to be able to run on the virtual agent (browserstack) as they are “mobile” tests. Thanks in advance.

Same issue here, yesterday it was working fine.