Tests/Jobs not running - "Register local agent"

I can’t currently run tests or jobs. All my agents are showing as available on the Agents page, but when I kick off Jobs they get stuck in the queue. And when I try to run a test against my own agent then it fails and says I need to register my agent. Restarting my agent doesn’t fix this. Anyone else hitting this issue?

3 Likes

My tests are getting queued indeed.
Like last time that happened to me, I might have to remove my agent and reinstall it and then re register it. I want to avoid that because it is running as a service on a server.

last time I got away with just deleting the agent from the TestProject Agent page (but not actually uninstalling the agent) and then just registering the same agent again, and it worked. It seems to have worked for my local agent now, so going to try that for our other agents.

1 Like

Try this

  1. Delete temporary agent files | TestProject Help Center
  2. Download the agent
  3. Register the agent
  4. Restart the agent, many times, it worked for me.

That seems to have worked for me.
Stop the agent from running.
Remove the agent from the TestPRoject agent page
Re-register the agent

Tests are running again now.

Hi all, seems problem with agent? Is there any query solution to understand if problem is ongoing or not automatically?

Deleting the agents from the Agents page on TestProject and registering them again fixed the issue for us. Not sure if that’s still required though, perhaps others would know.

This issue is extremely frustrating. If you re-register the agent, you have to re-add the agent to every single job you have, update the max worker load, and re-authorize mobile devices attached to each agent. As of this morning my agents are “un-registered” for the second time in the past 24 hours.

I can not register an Agent. Registration page is getting stuck. Any ideas?

4 Likes

unable to run/ execute tests and jobs at the moment… no progress on monitor page as well for the executions…

yep, once again had the same issue this morning. Once again I had to delete the agent from the Agents page and register it again. Having to do this with multiple agents every day is a real pain.

This is happening every other day now @asaf.saar

I have the same issue since last week. Every day i have to register the agents. I hope for a quick solution given that we have many agents…

1 Like

able to execute the tests now without having to uninstall the agent, however the jobs are not running…
not sure if we need to uninstall and reinstall the agents for this to run…

you need to re-assign the agents to the jobs which is complicated if you have many.