TestProject Agent wants access to control 'System Events'

Hello, I am reaching out on behalf of my team member who consistently is receiving “Test Project Agent” wants to access to control system events. So we went into Mac > Security > Automation and ‘checked’ the box that will allow us to give Test Project that access. Even after this happens and we try to run the recorder, it keeps popping up. After rebooting the machine it still does this as well.

He is on Mac Monteray 12.3.1
I have attached screen shots.

Is this an issue with Mac/admin/root settings, or is this something related to the test project agent? This is preventing him to use the recorder.

Also, I am running the same Mac/Version setup and I have never had this issue as well as a windows machine that does not behave this way.

Any guidance is appreciated.

Thanks,
Joey
Screen Shot 2022-04-08 at 1.55.31 PM

Hi @CassiereJ,
Give access to TestProject in the Accessibility settings under privacy:

Let me know if it solves the issue.

Hi @ran.ferdinaro - We followed the steps you mentioned by setting permissions in the ‘Accessibility’ menu. However, we are still facing this issue when you launch the recorder. Screen shots attached. Any other system settings should be set? This is strange as I have used this on many devices over time and never had this issue. thanks.



I have also attached the log files from the user. Thank you.

@CassiereJ
Please try the following solutions:

  1. Go to the ‘Notifications & Focus’ settings, turn off TestProject Agent, and restart your computer.
  2. Try to follow this guide.

If you are still facing this issue -

Please quit the TestProject Agent and then clean these folders:
coded-tests
data-sources
addons
apps
executions
logs
temp
workers-executions

also, delete the following file:
lock

You can find them here:

Windows

Open the Start menu, type %appdata%\TestProject\Agent\ and hit enter.

macOS
Open Files Finder and choose Go from the top menu, select Go to Folder and type:
~/Library/Application Support/TestProject/Agent

Linux
Navigate to ~/.testproject/agent/

Then, please do the following:

  1. Restart your Agent
  2. Reproduce the issue you encountered
  3. Send the agent logs of today for analysis to support@testproject.io .

You can download the logs and upload them here as shown below:

1 Like

Hi @ran.ferdinaro we got it working! thanks for your assistance. have a great day

@CassiereJ
Glad to hear you were able to solve it.
Can you please share with the community what helped solve the issue?