TestProject Forum

Testproject Agent stops while running Jobs

Hi Team,

We have scheduled Jobs that run every night, but from last few days, our agent is abruptly getting disconnected in middle of running the job.

Following is the error that we get in the logs.

2021-09-21 22:33:03.948 [ERROR] i.t.a.m.d.q                              Failed to execute step uLr01tRIYECRlU2_PWuw1A
org.openqa.selenium.WebDriverException: java.net.ConnectException: Connection refused
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:17:03'
System info: host: 'ip-172-31-4-230.ap-south-1.compute.internal', ip: '172.31.4.230', os.name: 'Linux', os.arch: 'amd64', os.version: '4.14.246-187.474.amzn2.x86_64', java.version: '13.0.1'
Driver info: org.openqa.selenium.remote.RemoteWebDriver
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 93.0.4577.82, chrome: {chromedriverVersion: 93.0.4577.63 (ff5c0da2ec0ad..., userDataDir: /tmp/.com.google.Chrome.TLLXRa}, goog:chromeOptions: {debuggerAddress: localhost:38313}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, proxy: Proxy(), setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:extension:credBlob: true, webauthn:extension:largeBlob: true, webauthn:virtualAuthenticators: true, webdriver.remote.sessionid: 442d1a97d7176909a78c3b65bb9...}
Session ID: 442d1a97d7176909a78c3b65bb95cfda
        at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at java.base/jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
        at java.base/java.lang.reflect.Constructor.newInstanceWithCaller(Constructor.java:500)
        at java.base/java.lang.reflect.Constructor.newInstance(Constructor.java:481)
        at org.openqa.selenium.remote.http.W3CHttpResponseCodec.createException(W3CHttpResponseCodec.java:187)
        at org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(W3CHttpResponseCodec.java:122)
        at org.openqa.selenium.remote.http.W3CHttpResponseCodec.decode(W3CHttpResponseCodec.java:49)
        at org.openqa.selenium.remote.HttpCommandExecutor.execute(HttpCommandExecutor.java:158)
        at org.openqa.selenium.remote.RemoteWebDriver.execute(RemoteWebDriver.java:552)
        at org.openqa.selenium.remote.RemoteWebDriver$RemoteWebDriverOptions$RemoteTimeouts.implicitlyWait(RemoteWebDriver.java:780)
        at io.testproject.agent.managers.d.q.b(TestProjectAgent:913)
        at io.testproject.agent.managers.d.q.d(TestProjectAgent:1637)
        at io.testproject.agent.managers.d.q.a(TestProjectAgent:2512)
        at io.testproject.agent.managers.d.q.a(TestProjectAgent:300)
        at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
        at io.testproject.agent.c.d.run(TestProjectAgent:33)
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
        at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
        at java.base/java.lang.Thread.run(Thread.java:830)

Hi @vmishra,
Please send us the full logs and a share with us a test that reproduces this issue, recorder or coded to
support@testproject.io
Once we have all the information we will check and update here as well.

I was using agent 2.1.1, I have upgraded the agent…will share logs as soon as the next crash occurs.

Thanks for the update,
I am closing this topic, if you are still experiencing this issue please contact us directly on our live chat or on our support mail.

Live chat can be found on the bottom right corner:

Or on our support mail:
support@testproject.io