TestProject Forum

Testproject agent not working

Some QAs are facing this issue that the testproject agent v.30 isnt woking.
System is Ubuntu

known issue, related to connectivity/dns problems in some geographical location. currently taking care by our infrastructure team. should be fixed within next few hours we will post here once the issue is sorted.

should be back to normal now, please confirm or let us know if you still experience any issues

I was also facing the same issue & one of support team member asked me to unregister the agent & then again register the agent . Now it’s like blocked condition , because I am unable to register the agent facing issue in that , Please suggest me the solution & one more thing if I unregistered the agent then do I need to do all configuration again.

Thanks for your help and the effort of the team, but somehow the issue is still happening. I have tried even on a different computer and different mobiles. Is this somehow a regional issue? (My region/ip is Asia - Vietnam)

The issue was related to Asia’n region, can someone check if it still there?

Thanks for providing new agent version , but still facing same issue . It’s not working.

1 Like

This isn’t just for the Asia region. I’m from the UK and I am getting the same issue with the devices and agent not working.

Hi Ian, can you please try open the following URLs in your browser and let us know if it works

https://ping.testproject.io
https://baidu.com

Hi Mark,

Yes, they all worked fine.

Ok we are working on that, it’s mostly Asians outage, in a meanwhile, try to unregister your agent, delete the agent folder from the user\app data folder, delete the agent record from tp agents tab, reset your machine , download the new version of the agent and register it again. lets us know if helps.

Tried your suggestion but upon attempting a screen simulation I am getting the following error.
image

Hi Ian, this is not the same issue as addressed in this topic.
Which device are you trying to mirror?

Samsung Android Tablet

You say that but it’s extremely intermittent. Yesterday, the device wasn’t being detected at all, today with the updated agent it now has. However, if I was to disconnect/connect the device to the laptop the agent won’t always acknowledge it.

The issue discussed here is about the agent not connecting.
This is a different issue then, can you please send your agent logs to support@testproject.io

How do you download the agent with-out being able to login?

Can confirm that was the case for me as well.
I am located in Norway, and had major problems accessing app.testproject.io yesterday from around 14:00 CET until 23:00 CET

We aware of the issues folks that were yesterday mainly affected Asia, the infrastructure teams were on top of it, it should be gone now. please try again. regarding the page that not opened sometime it related to cache, try CTRL+SHIT+R or cleaning the cookies/cache manually. please let us know

Thanks for your help and for the team efforts. It’s working now. Thanks