TestProject Agent is running but I get "Local agent is unavailable"

Hi,

I tried to connect my device to continue test record but don’t connect my device and popup the “Local agent is unavailable.”

Please, let your comment to help me. Thank you

Screen Shot 2022-10-12 at 1.59.38 PM

I tried to register a new augent, Now it work as normal.
Agents > Register Agents

Now, It’s working normal.

1 Like

Not working for me on latest OS Mac. Seems to be unstable on Mac, ran into this before. Will try on Windows now.

Double check if your agent is disconnected status in Agents > Disconnected.
Try to end process the agent in your machine’s task manager and open it again.

If the above mentioned are still not working, try to delete the current agent and make a new one.

Web page shows that it is connected and device is green and authorized. Yet when I try and view device it says agent is not there. I have determined it is the Verizon MIFI that is causing the issue. Hotspot from my tMobile phone or use a router based wifi then it works fine. Sucks cause I use the Mifi from my RV and I am completely remote now with it, traveling the USA. But I can’t use this site when I do so. So by test project I’ll stick with writing Appium scripts.