TestProject Forum

TestProject Agent gets disconnected often [SOLVED]

Hi, Some days TestProject Agents gets disconnected often, when the Agent is in disconnected state i cannot even take logs.
image

Is there any workaround or fix for this issue, I already tried “Restart” Agent then “Quit” and “Restart” nothing worked until i restarted my computer.

Thanks,

The issue is still exist with Agent

Hello @sahanijuttukon
Can you tell me which Agent version are you using?
Did you try to delete your Agent from the Agents tab and register it again?
Are you using any VPN/Proxy/antivirus?
You can not download the logs from the UI when the agent is disconnected, you can only do so when the Agent is connected.
You can get the logs from the logs folder, which OS are you using?

Hi @kfir.yosef Thanks for your reply
I am using 3.0.5 version agent, but i used to face this issue with lower versions 2.0. as well
Yes, I tried delete agent once but it did not help
Yes, I am using VPN
I am using Windows OS, this problem i noticed in MAC as well

Hey, @sahanijuttukon
First, please try to install Agent 3.1.0 version.
Have you tried working without the VPN If so, is it still happening?
If not, can you try and tell me if there is a change?
If you still facing this issue with this version, please send us the Agent logs to support@testproject.io with all the info and we will check this out.

Windows

Open the Start menu, type %appdata%\TestProject\Agent\logs and hit enter.

macOS

Open Files Finder and choose Go from the top menu, select Go to Folder and type:
~/Library/Application Support/TestProject/Agent

@kfir.yosef Thanks for the info, let me try Installing 3.1.0 version Agent, will let you know if i see anything different.

Thanks