Test Project is unable to find the element on the page

I have recorded a test and tried to execute the same, There I am getting an error as “Element not found” for a particular field, Test Project is not finding the element on that Page.
but if we check the DOM manually, the element is there on the page with the same XPATH as what was recorded.
Please let us know what is going wrong here.

can you provide some more information on this? This usually does not happen, but in this case, what exactly is the error, which function are you testing etc…

Hi. Kindly find the below snaps for more details. Getting No matches in test project but the same xpath is getting identified in DOM .

Test Project Snap1:

DOM Snap 2:

image

This is a dynamic element and can change. U need to find xpath by text + additional paraments

Hi. I have tried using text xpath as well. getting same issue

No, it can’t be. Anything can be found with xpath. I would help you find the element. Sent the full xpath in the DOM with a screenshot to the desired element

I have tried using below text xpath also tried with different Xpath. getting same issue

very strange. What u need ? Button element? And which action u used in TP?

I want to click search button, used click action.

Hmm then u need to Button element not “i” tag

Required field button getting highlighted for the mentioned xpath. Do I need to modify

I’m also having a similar error. Sometimes when I run my test it works, but other times the test times out when trying to locate the element. One of the selectors change, but the ones it checks first don’t. Possibly a new bug?

Hmm… in ur system perform the search by Enter button on keyboard?