Test Execution report is not shown

I have 2 environments, one is mac physical machine which is being used for development, second one is AWS windows instance used for testing On both machines same account is configured.

Report can be seen for Any test executed on physical MAC machine, however report cannot be seen for tests executed on AWS instance, while I can see tests in execution on AWS instance.

just adding to this issue, for me is happening the same but for a phisical agent on Linux(pop_os), execution occurs normally but reports are not logged nor test updated. I ran on other linux agents (Ubuntu) and reports are logged, I tried reinstalling Agent, installing and older version of the Agent, still I’m not getting the report or test updated.

Are you able to resolve this issue? Normally what is the reply time from TestProject ?

Testproject has not replied yet, my workaround sadly is to use other test agents that are not on my computer.

Hi @mdeleon,

TestProject supports Ubuntu 16.04, 18.04 and 20.04. Perhaps the pop_op distribution is not supported.

Hi @sarfraz,

Can you please elaborate on how exactly you executed the test? Did you use the agent CLI or cloud execution?

Hi @amit.yahav ,
Thank you for looking into this issue.

I am using cloud execution on both environments, Mac and Windows.

Mac is a physical Machine
Windows is an AWS Instance.

Any test executed on MAC generates report, Where as any test executed on Windows(AWS) its shows execution but no report is generated.

Please let me know if you need more information.

Can you access the agent logs on the Windows machine?

Hi @amit.yahav ,Yes I can access, but not sure, how to share with you ?

@sarfraz

Can you please execute the same test again, zip the execution folder under Agent’s data folder, and send it to support@testproject.io?

Hi @marat ,

I have sent the requested log files on the mentioned email address. I request a quick analysis and response on this.

Thanks.
Sarfraz Hussain

Hi,

We are also facing the same issue. We could not see the test reports once execution is completed.

2 Likes

Hi Team,

I am unable to see the latest executions and reports after running a test script. This has been happening since today morning.

Could you please check once?

Attached is the screenshot for the latest executions it doesn’t show any execution for today i.e. 23/06/2022

I will be sharing the Agent logs on support mail.

Thank you

Regards,
Gourav Kumar Singh

4 Likes

Same here. From today I cannot see any new reports.
Also I cannot delete old reports.

3 Likes

Yes, Facing the same issue with us also. Do we have any ETA for this issue to get fixed?

Thanks

3 Likes

Hi @Gourav.singh
Even i am facing the same issue.
Please drop a solution if you find any.
Thanks :slight_smile:

2 Likes

Same problem for me. Could be a global issue?

2 Likes

Hi Team,

Any updates on the above issue?

Thank you

Regards,
Gourav Kumar Singh

today it is still happening, any novelty about it?

As a workaround, I restart the agent from the quick launch and kicking off the test again. This is for the issue when the test doesn’t run after initializing.