Test execution is failing with docker based agent deployment at Pause step

Hi,
I am executing a test which has a pause of 5 minutes ( which is required as per product implementation), when I run this test using headless browser on a Linux based docker agent (configured for permanent mode) it is failing at the step where I have give Pause for 300000 ms.
Below is the error message from testproject for the failed step:

Unable to route (POST) /session/6a2c4dc6b26aef77b75bf44facfc1306/timeouts
Build info: version: '3.141.59', revision: 'e82be7d358', time: '2018-11-14T08:17:03'
System info: host: 'a1ed386a7878', ip: '172.24.0.4', os.name: 'Linux', os.arch: 'amd64', os.version: '3.10.0-1127.19.1.el7.x86_64', java.version: '13-ea'
Driver info: org.openqa.selenium.remote.RemoteWebDriver
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 96.0.4664.110, chrome: {chromedriverVersion: 96.0.4664.45 (76e4c1bb2ab46..., userDataDir: /tmp/.com.google.Chrome.ojGXvd}, goog:chromeOptions: {debuggerAddress: localhost:37442}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, proxy: Proxy(), se:cdp: ws://172.24.0.3:4444/sessio..., se:cdpVersion: 96.0.4664.110, se:vnc: ws://172.24.0.3:4444/sessio..., se:vncEnabled: true, se:vncLocalAddress: ws://172.24.0.3:7900, setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:extension:credBlob: true, webauthn:extension:largeBlob: true, webauthn:virtualAuthenticators: true}
Session ID: 6a2c4dc6b26aef77b75bf44facfc1306
Unable to route (GET) /session/6a2c4dc6b26aef77b75bf44facfc1306/alert/text

If I run the same test on a windows agent with UI based browser I do not face this issue. So it looks like there is a timeout occurring which is causing above failure.
Can someone please help in troubleshooting and fixing this issue?

Thanks
Ravi

1 Like

Hi @ravi_kakadia.

I have opened a ticket on this issue,

You will be notified here once it’s resolved.

This is the ticket number: TP-17153

1 Like

Hi @ravi_kakadia.

The problem was with the docker’s environment variable, SE_NODE SESSION_TIMEOUT which was set to 300 sec in Chrome and Firefox containers
to fix this you can edit the docker-compose file:

screenshot-1

Please let us know if it solved the issue.

I am able to run the test successfully after setting SE_NODE_SESSION_TIMEOUT to 600.
Thanks.

This topic was automatically closed after 180 days. New replies are no longer allowed.