TestProject Forum

'Session does not exist' Error when running jobs

I created a job with multiple tests and I’m getting a Session does not exist error after the first test has run. The remaining tests never run. I can run the tests individually, not in a job together.

Here is the error:

Failed to execute test ‘PRO3650’ on Appium_iOS on 00008030-001629D63A86802E: Session does not exist
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:17:03’
System info: host: ‘Brandons-Mac-mini.local’, ip: ‘192.168.0.107’, os.name: ‘Mac OS X’, os.arch: ‘x86_64’, os.version: ‘10.16’, java.version: ‘13.0.1’
Driver info: io.appium.java_client.ios.IOSDriver
Capabilities {ScaleFactor: 2, automationName: XCuiTest, browserName: , bundleId: com.subzero.group.owners.dev, databaseEnabled: false, deviceName: Connected iPhone 11, forceAppLaunch: true, javascriptEnabled: true, locationContextEnabled: false, networkConnectionEnabled: false, newCommandTimeout: 0, noReset: true, platform: MAC, platformName: iOS, platformVersion: 14.8.1, realDevice: true, shouldTerminateApp: true, simpleIsVisibleCheck: true, skipDeviceDetect: true, takesScreenshot: true, udid: 00008030-001629D63A86802E, useExternalWDA: true, usePrebuiltWDA: true, waitForQuiescence: false, webDriverAgentUrl: http://localhost:61902, webStorageEnabled: false}
Session ID: 2fd67ed4-c9b7-4ac1-accd-ef88a84d1ce1

First of all, welcome to the community @Bryan.Jadrich :slight_smile:
Would you please follow these steps

  1. Restart your Agent
  2. Reproduce the issue you encountered
  3. Send us the agent logs of today for analysis. To our support mail:
    support@testproject.io

Hey Alex,

I don’t have the option to download the logs that way. image001.png