TestProject Forum
Powered by leading experts in the test automation community

Screenshot error - The request signature we calculated does not match the signature' error

When I run a test and take a screenshot on failure then I do not see the screenshot under test reports
If I try to open the screenshot in another tab I see an AWS error

The URL to the missing screenshot
https://storage-euw1-data.testproject.io/SJbQGSwJ3Uqls6Zeai-Ayw/project/Esr_cX3v7kufWKdEa2ahRw/report/EtC076TvJ0enoNg60-rANA/thumbnail/MNW3-6zXRtOZzUdbhog-4g?X-Amz-Expires=604800&X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=%2F20200805%2Feu-west-1%2Fs3%2Faws4_request&X-Amz-Date=20200805T163012Z&X-Amz-SignedHeaders=host&X-Amz-Signature=

The error page
This XML file does not appear to have any style information associated with it. The document tree is shown below.

SignatureDoesNotMatch

The request signature we calculated does not match the signature you provided. Check your key and signing method.

*******

AWS4-HMAC-SHA256 20200805T163012Z 20200805/eu-west-1/s3/aws4_request db88dbc07381267bcb857a95284d636541498d7c39afec5a88c235ce64e8ed93

*******

41 ***************************61 38 38 63 32 33 35 63 65 36 34 65 38 65 64 39 33

GET /SJbQGSwJ3Uqls6Zeai-Ayw/project/Esr_cX3v7kufWKdEa2ahRw/report/EtC076TvJ0enoNg60-rANA/thumbnail/MNW3-6zXRtOZzUdbhog-4g X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=*******%2F20200805%2Feu-west-1%2Fs3%2Faws4_request&X-Amz-Date=20200805T163012Z&X-Amz-Expires=604800&X-Amz-SignedHeaders=host host:storage-euw1-data.testproject.io host UNSIGNED-PAYLOAD

47 45 ******* 4c 4f 41 44

720F4133FBE74AB6

i8uR+w*******gpmRQ6I7DtwIb0mjce7M/vrfDoVKbqW3QtwCF1qsvBEUt/DKBog=

Hello @magnush.

Depending on your connection it may take some time for the screenshots to load.
Are the images still not displayed? Does this happen consistently?

Yes, it is fairly consistent.
Checked again just now and one screenshot was displayed, while another from the same test did not display

Can you please contact us in the support chat to continue this conversation?
You can access the support chat from this icon on the site:

image

Thanks, on test again just now it looks to be working immediately.
Should it happen again I will start a chat.