TestProject Forum

Runtime error on CLI when recorder is running

When executing the run command for a test via the CLI whilst the recorder is open a runtime exception is returned

io.grpc.StatusRuntimeException: UNKNOWN
at io.grpc.Status.asRuntimeException(Status.java:533)
at io.grpc.stub.ClientCalls$BlockingResponseStream.hasNext(ClientCalls.java:629)
at io.testproject.agent.cli.commands.RunCommand.a(TestProjectAgent:188)
at io.testproject.agent.cli.commands.RunCommand.call(TestProjectAgent:45)
at picocli.CommandLine.executeUserObject(CommandLine.java:1953)
at picocli.CommandLine.access$1300(CommandLine.java:145)
at picocli.CommandLine$RunLast.executeUserObjectOfLastSubcommandWithSameParent(CommandLine.java:2352)
at picocli.CommandLine$RunLast.handle(CommandLine.java:2346)
at picocli.CommandLine$RunLast.handle(CommandLine.java:2311)
at picocli.CommandLine$AbstractParseResultHandler.execute(CommandLine.java:2179)
at picocli.CommandLine.execute(CommandLine.java:2078)
at io.testproject.agent.cli.Program.main(TestProjectAgent:80)

Hello @ryan.howard
Thank you, this will be addressed.

got the same error even the recorder is closed. I always got this on my other machine, to my other machine it works fine
io.grpc.StatusRuntimeException: UNKNOWN
at io.grpc.Status.asRuntimeException(Status.java:533)
at io.grpc.stub.ClientCalls$BlockingResponseStream.hasNext(ClientCalls.java:629)
at io.testproject.agent.cli.commands.RunCommand.a(TestProjectAgent:188)
at io.testproject.agent.cli.commands.RunCommand.call(TestProjectAgent:45)
at picocli.CommandLine.executeUserObject(CommandLine.java:1953)
at picocli.CommandLine.access$1300(CommandLine.java:145)
at picocli.CommandLine$RunLast.executeUserObjectOfLastSubcommandWithSameParent(CommandLine.java:2352)
at picocli.CommandLine$RunLast.handle(CommandLine.java:2346)
at picocli.CommandLine$RunLast.handle(CommandLine.java:2311)
at picocli.CommandLine$AbstractParseResultHandler.execute(CommandLine.java:2179)
at picocli.CommandLine.execute(CommandLine.java:2078)
at io.testproject.agent.cli.Program.main(TestProjectAgent:80)

Hi @ryan.howard, @tingtest834

This issue has been fixed.
Please update to the latest agent version (2.1.0)

https://app.testproject.io/#/download