Reports are not getting generated in testProject.io from Morning

Looks like the results/reports are not getting generated after test executions since Morning.
I have ran multiple jobs and scripts, reports are not shown in Reports and Monitor screens.

Anyone else seeing the same issue?

4 Likes

yes we are also facing same issue , till yesterday it was working fine , but from today morning it’s not working.

2 Likes

We also have the same issue, no reports are saved so error detection not possible for the running tests !

same issue for me. report is not working. I deleted all previous reports and also re install agent, but seems like still not working.
here is a log file. seems like report endpoint return 503 error. I removed my projectID and executionID

Combined 1 reports for execution xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
2022-11-28T00:40:57.8834270Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:57.882 e[34m[INFO ]e[0;39m i.t.a.m.w.b Starting reports uploading…
2022-11-28T00:40:57.8852071Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:57.884 e[34m[INFO ]e[0;39m i.t.a.m.d.p There are 1 execution reports pending to be uploaded
2022-11-28T00:40:57.8928347Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:57.891 e[34m[INFO ]e[0;39m i.t.a.m.d.p Initiating upload for execution report xxxxxxxxxxxxxxx
2022-11-28T00:40:57.8948568Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:57.894 e[34m[INFO ]e[0;39m i.t.a.m.d.p Finished reporting task
2022-11-28T00:40:58.0586241Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:58.057 e[34m[INFO ]e[0;39m i.t.a.m.d.p Submitting report for execution xxxxxxxxxxxxxx
2022-11-28T00:40:58.6439552Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:58.642 e[1;31m[ERROR]e[0;39m i.t.a.b.a.d POST https://api.testproject.io/executions/results/projects/xxxxxxxxxxxx/executions/xxxxxxxxxxxxxx/report - 503 (null): No Message
2022-11-28T00:40:58.6472766Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:58.644 e[1;31m[ERROR]e[0;39m i.t.a.b.a.c POST https://api.testproject.io/executions/results/projects/xxxxxxxxxxxx/executions/xxxxxxxxxxx/report - 503 (null): null
2022-11-28T00:40:58.6485468Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:58.647 e[31m[WARN ]e[0;39m i.t.a.b.b.h Failed sending report:
2022-11-28T00:40:59.2209023Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.219 e[1;31m[ERROR]e[0;39m i.t.a.b.a.d POST https://api.testproject.io/executions/results/projects/xxxxxxxxxxxxxxxx/executions/xxxxxxxxxx/report - 503 (null): No Message
2022-11-28T00:40:59.2212506Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.220 e[1;31m[ERROR]e[0;39m i.t.a.b.a.c POST https://api.testproject.io/executions/results/projects/xxxxxxxxxxxxxxxx/executions/xxxxxxxxxxxx/report - 503 (null): null
2022-11-28T00:40:59.2216432Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.220 e[31m[WARN ]e[0;39m i.t.a.b.b.h Failed sending report:
2022-11-28T00:40:59.7904872Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.787 e[1;31m[ERROR]e[0;39m i.t.a.b.a.d POST https://api.testproject.io/executions/results/projects/xxxxxxxxxxxxxx/executions/xxxxxxxxxxx/report - 503 (null): No Message
2022-11-28T00:40:59.7908496Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.788 e[1;31m[ERROR]e[0;39m i.t.a.b.a.c POST https://api.testproject.io/executions/results/projects/xxxxxxxxxxxx/executions/xxxxxxxx/report - 503 (null): null
2022-11-28T00:40:59.7911208Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.788 e[31m[WARN ]e[0;39m i.t.a.b.b.h Failed sending report:
2022-11-28T00:40:59.7913410Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.789 e[31m[WARN ]e[0;39m i.t.a.m.d.p All 3 attempts to upload report for execution xxxxxxxxxxxx have failed
2022-11-28T00:40:59.7954362Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.791 e[1;31m[ERROR]e[0;39m i.t.a.m.d.p Failed to submit report
2022-11-28T00:40:59.7957394Z e[36mtestproject-agent |e[0m 2022-11-28 00:40:59.791 e[34m[INFO ]e[0;39m i.t.a.m.d.p Deleting execution folder xxxxxxxxxxxxxx

Yes, I am also having issues with the reporting.
Last night my regression tests ran, and I only have very few reports.
Now no test seems to be able to generate a report.

I am also facing the same issue from morning, still it is the same for me.
Do you guys able to see the reports now?

On our end it has started working.

1 Like

Now reports are getting generated !!

In our case, the reports still do not appear, I am from Lima Peru.
I just tried about 5 minutes ago…

Not every reports is generated

1 Like

same for me. only generated 5 reports and then it was stop with same error . Error 503

the report generation is very unstable, sometimes it works, sometimes it doesn’t…

still not working for me , even after i restarted the agent !

For me its still the same, I tried restarting the agent as well

1 Like

Still reports are not working

1 Like

Reports are still not being generated correctly. Sometimes they are and other times they are not.
Really annoying when you are trying to run your regression tests.

1 Like

Same issue for me as well for today.

Our team is also facing this issue today….

Anyone able to get the reports? If so please help us getting the logs.
I tried restarting the Agent and re-registering the agent as well, but no success

When executed 8 jobs reports are generated only for 4 jobs