Renaming application elements is not reflected in test scenarios

I have some test scenarios that have recorded some elements for the first time, and assigned a name to them based on their HTML attributes (in this case, the CSS selector ID).

When I rename the element, then go back to the test scenario which is using it within a step, I noticed that the element’s new name is not reflected within the test.

In this example, the step to record the username and password fields, recorded the elements as “username” and “password” (based on their CSS IDs).

I went to the ‘Elements’ section, chose the appropriate application, and renamed the elements to “‘Username’ input field” and “‘Password’ input field”. (see screenshot 1)

But when I returned to the test scenario, the element name has not changed. This may cause potential issues later, as that element name no longer has meaning within the ‘Elements’ section. In screenshot 2, you can see, I am having to manually edit these myself.

1 Like

That’s interesting, I will see if I can reproduce it too.

Hi @james.storey, I just tried this and the element name changes for me automatically. I thought it was the single quote causing issues but that works for me as well. There must be a step missing for me to reproduce this.

As we are unable to reproduce this,
This is probably due to the element being a different element or not containing the same locators, also can you please make sure to go out and back into recording mode?
I’m changing this issue to solved incase the issue persist please contact us directly on our support chat.

This topic was automatically closed after 180 days. New replies are no longer allowed.