Recording a new test tells me to login with chrome when I am logged in from chrome

Every time I try to record new steps for a test, TestProject gives me an error and tells me I have to be logged in from chrome. I am logged in on chrome, I registered the agent using my login from chrome, and I created the project and test using chrome, but I still get this error.

I am running on Mac OS. I have Safari and FireFire installed as well as Chrome for cross browser testing. I don’t know if the TestProject Agent requires me to have Chrome set as my default browser or not, and I have not tried this yet because that is problematic for me at this point. I am hoping someone has some ideas on how to get the agent to recognize that I am logged in with Chrome.

I am very new to TestProject so I can only assume I am just not doing something properly.

Thanks for any help!

I have noticed that when I look at the agent under the agents tab on the testproject account, in the Browsers section it says Safari. I am unable to see a way to change that. Maybe this is a hint as to why it is not working because it is trying to use Safari.

I should have noted above that my default browser is Firefox. I don’t see any indication that firefox or Safari are currently running right now though. I closed them both to make sure it wasn’t just finding the first browser process it sees or something.

Thanks again for any help.

Just to update this thread, changing my default browser did not change the behavior I am seeing. The only browser the agent will see appears to be Safari.

Yes. I too facing the same issue. Hope TP support team will revert with answers on how to remove Safari as default browser for MacOS or release updated version with other browsers like Chrome & FF. I don’t see problem in Windows because all 4 major browsers are added into agent.

Issue is resolved now. Performed the below steps.

  • Downloaded Google Chrome browser
  • Moved the Chrome setup file to Applications
  • Logoff and Login
  • Goto System Preferences >> General >> Default Web Browsers >> Select Google Chrome
  • Goto Test Project & do Web test.
  • Record & Playback was successful.

Same issue and my default browser is Chrome. Any other solution?

1 Like