Recorder is not working

I was working on testproject from long time , but didn’t face this kind of issue earlier . suddenly recorder has stopped working . when try to open recorder then getting error - " Couldn’t connect to agent of device (iphone)". I am stuck with this issue . so need urgent help on this .

Hi @mukta, please do the following:

  • Restart the TestProject agent.
  • Reboot the machine.
  • Make sure you are using the latest agent (Currently 3.5.0).

If all methods fail please contact us at support@testproject.io with the agent logs which can be found here: TestProject Agent Logs | TestProject Help Center

Hi @ran.ferdinaro ,
I have tried all mentioned methods & even I have deleted my agent & registered new agent . But still I am getting the same error. I am sending the agent logs on support.

I am facing the same the issue from yesterday after installing new agent 3.5.0, Recorder or even edit isn’t working. Can any one please help regarding that ? thanks

Hi, I think all the users are facing this issue. The recorder and some platform functionalities are behaving erratically. There are a lot of threads in the forum regarding this. We will have to wait for the TestProject team to solve these issues. I think they are migrating their services.

1 Like


Even reports can’t be downloaded and recorder isn’t working ! Please have a look or tell at least the users , so that we can wait for it. thanks

Hi all,
We have made significant progress, and the issue regarding the recorder should be resolved.
As you know, our team is working to resolve these issues as soon as possible.
TestProject is currently undergoing a migration process, so you might occasionally encounter some downtime.

If you are still facing related issues, try the following solutions:

  1. Follow this document to empty cache.
  2. Restart your computer.

If you are still experiencing these issues after following said solutions:

  1. Restart your agent.
  2. Reproduce the issue.
  3. Send the agent logs of today for analysis to support@testproject.io

You can download the logs and upload them here as shown below:

Sorry in advance for the inconvenience.