Recorder doesn’t recognise some elements (iOS Native application)

I didn’t find any element in the textfield, in the layout that seemed to cover it, this happened when I was going to record through a real device on iOS.

Hi @maychel.hutahaean,
iOS apps are parsed by XCUITest - a tool made by Apple.
If you cannot find elements it might be due to a timeout after XCUITest is trying to parse your elements (15 seconds).
If this is the case, It usually means that there are either a large number of elements in the app or an issue with the app’s optimization.

Does this happen on all pages of this app?
Are you able to see the elements in the ‘Explorer’ tab?
Does it happen in other apps (Calculator, e.g.)?

If not, you might need to tap on a specific part of a mobile element (both Android or iOS); you can use the ‘Tap element at relative point’ action.

You can hover the wrapper element of the element you want to tap on, double shift to capture it, and select the “Tap at relative point” action, by providing the Horizontal tap percentage and the Vertical tap percentage (notice: it starts from the top-left corner of the element) you will be able to tap on a specific point on the wrapper element.

Here you can read more about it and find an example:

but when the record is not active, it can be done

Can you share a video showing the difference between the modes and show the issue?
If you cannot send it here, please send it to support@testproject.io .

@maychel.hutahaean

The mirrored windows recognize the coordinates you used when clicking on the element.
However, the recorder is searching for elements.
For this reason, I mentioned the option to use the ‘Tap at relative point’ action in the previous message.

I’ve tried to tap at relative point, but what I get is still the same, I can’t get the record of the textfield.

please help @ran.ferdinaro

@maychel.hutahaean In order to write into a textbox, you need your app to be parsed correctly.

  1. navigate to the test.
  2. Open the inspect tool and open the network tab.
  3. Press ‘view device’ and watch for the requests sent.
    If you see that the parsing request gets a timeout error, It usually means that there are either too many elements in the app or that there is an issue with the app’s optimization.
    The solution for this issue is to ask your developers to debug the app in Xcode and search for issues with the optimization (for example - some layers of elements are stayed behind instead of being removed, or there are too many elements for XCUITest to parse during the fixed time).
  1. this is the result when I open inspect and view device.
  2. how many max elements in apps should be?
  3. app developers have not implemented xcuitest

https://drive.google.com/drive/folders/11sMmsNRd1j7busvOjBt5OowXM7VFm3gc?usp=sharing

Hi @maychel.hutahaean,

You need to open the network tab and open your app to be able to see the process. You will be able to see the time and information for every request there.
There is not enough information in the video you sent, and you need to do it inside your app. Also, pay attention to the time of each request.

The max amount of elements cannot be too large, so it will take more than 15 seconds for XCUITest to parse them.

XCUITest is a tool created by Apple.
In our case (testing on iOS devices), it is used to parse elements (among other things).
You can read more about it here:
https://appium.io/docs/en/drivers/ios-xcuitest/