TestProject Forum
Powered by leading experts in the test automation community

Radio button not getting selected

Hello, I am unable to select both, a radio button and a checkbox in the application i am trying to test using this tool.

Any help would be appreciated.

Thanks,
Ankita

Hello and thanks for reaching out to us.

Are you getting an error or timeout when attempting to select the checkbox?
In case you are, please screenshot it and send it here.

In general to select a checkbox, you will need to use the click action on it:

2

Make sure you are selecting the checkbox element when performing the click.
You can also use click using JavaScript (web) and tap (mobile).

Hi, have attached the screenshot. The action Click is added but not being performed. Have increased the wait time as well but it still stays element not visible until timeout

Hi @diabolique.me , when you are in the recorder and click the find button in the step menu, does it find the radio button? (Flashes in green).
If it does not, you need to find the static part of the element as it probably changes between executions.
You can read more on how to find dynamic elements in this article: https://intercom.help/testprojectio/en/articles/3572418-how-to-create-dynamic-elements-in-testproject

Hi, i checked for the checkbox and yes it does. When i click on find, it gets green and i get the message “Element Locator 1 match” but on running the same step again, it fails. Screenshot attached.

hi, i tried with javascript and it worked!

Great, that is just what I wanted to suggest :slight_smile:
Feel free to reach out for anything else.

Best Regards, Ran.

Sure. Thank You! :slight_smile: