TestProject Forum

Private parameters appear when calling a script in a testscript

When I want to reuse a testscript, you can define the parameters as input, output and private. When I run this test, only the input parameters are asked from the user at the start of the test.
At the moment I want to reuse the script in another script, all parameters are shown as input parameters, except the output, they are mentioned in the output part.
I explicitly defined the parameters as private so they can’t be changed from outside the script.
Is there a way to get this correctly, or as expected, working?

Hi, ar.vanberkum,
Are you sure you set the parameters to be private before adding the subtest?
It’s not reproducible on my end, can you make sure you first set them to be private and only then add a test as a step?
Let me know if this solved your issue.

Hi Amit,

Thanks for your response.

What I found out is that at the moment you want to include a test with parameters into your script, all the parameters, also the private ones are shown. When you use the test as a step, only the in and out-parameters are shown. Imho, this is a little confusing and I would like that those private parameters are not shown when I select the test.

Regards,

Ruud van Berkum

Test en Performance specialist| Avans Hogeschool | 06 12 072 918 | Postbus 90.116 | 4800 RA Breda | avans.nl |