"On first iteration invalid session id"

We have an agent to schedule regression tests for one of our platforms. This agent runs perpetually in Azure Container Registry through a docker compose file:

version: "3.1"

volumes:
  testprojectagents:
    driver: azure_file
    driver_opts:
      share_name: testprojectagents
      storage_account_name: <STORAGEACCOUNTNAME>

services:
  testproject-agent:
    image: testproject/agent:latest
    depends_on:
      - chrome
    volumes:
      - testprojectagents:/var/testproject/agent
    environment:
      TP_API_KEY: "<KEY>"
      TP_AGENT_ALIAS: "<NAME>"
      CHROME: "chrome:4444"  
  chrome:
    image: selenium/standalone-chrome
    shm_size: '1gb'

This has been working fine for months, but since a couple of days I keep getting:

On first iteration invalid session id
Build info: version: '4.1.1', revision: 'e8fcc2cecf'
System info: host: 'SandboxHost-637849318702525802', ip: '127.0.0.1', os.name: 'Linux', os.arch: 'amd64', os.version: '5.4.81-microsoft-standard', java.version: '13-ea'
Driver info: org.openqa.selenium.remote.RemoteWebDriver
Command: [bee2e4dfb1793f6d0eeecd5b8ebb1474, setTimeout {implicit=35000}]
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 100.0.4896.75, chrome: {chromedriverVersion: 100.0.4896.60 (6a5d10861ce8..., userDataDir: /tmp/.com.google.Chrome.NEtZPM}, goog:chromeOptions: {debuggerAddress: localhost:46409}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: LINUX, platformName: LINUX, proxy: Proxy(), se:cdp: ws://192.168.0.138:4444/ses..., se:cdpVersion: 100.0.4896.75, se:vnc: ws://192.168.0.138:4444/ses..., se:vncEnabled: true, se:vncLocalAddress: ws://192.168.0.138:7900, setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:extension:credBlob: true, webauthn:extension:largeBlob: true, webauthn:virtualAuthenticators: true}
Session ID: bee2e4dfb1793f6d0eeecd5b8ebb1474
invalid session id

I have tried everything I can think of, like recreating the docker image, agent in testproject etc. But I cannot figure out why this is failing. Can someone point me in the right direction?

Hi @KLGm,
We had an issue on our side that may have caused this issue on your end.
Please try again and let me know if it works.

Hi, I tested it again today, but I keep getting the same error. On my first test the first run worked, but second one failed again with the invalid session error. Any other tests after all failed with the invalid session id error.

Do you have any other things I could test?

Thank you for the information.

Hi @KLG ,
We have made significant progress, and the issue regarding the recorder should be resolved.
As you know, our team is working to resolve these issues as soon as possible.
TestProject is currently undergoing a migration process, so you might occasionally encounter some downtime.

If you are still facing related issues, try the following solutions:

  1. Follow this document to empty cache.
  2. Restart your computer.

If you are still experiencing these issues after following said solutions:

  1. Restart your agent.
  2. Reproduce the issue.
  3. Send the agent logs of today for analysis to support@testproject.io

You can download the logs and upload them here as shown below:

Sorry in advance for the inconvenience.