Not able upload code

@nidhi.sharma
Did you find the solution?
I tried with just one test class and followed all the steps mentioned in their documents. I can able to upload the code. However I am unable to run the uploaded code.

If I tried to upload all the classes of my project I am facing similar error. Did you find the solution? If Yes please share

TIA

This error can happen if the IDE could not find the selected board on the port, or if a port is not selected.

Make sure the board is connected to your computer.

Make sure that the right board is selected in Tools > Board.

Select the board in Tools > Port.

For step-by-step instructions, see Select board and port in Arduino IDE.
If you can’t find the port, see If your board does not appear in the port menu.
Make sure the correct port is selected in Tools > Port.

Close other instances of Arduino IDE, serial monitors, and other software that may be blocking the port.

Restart your computer.

See Find and stop process blocking a port.

Greeting,
Rachel Gomez

@rachelgomez161999
I am using eclipse IDE. Could you please help with this IDE?
Please share more info about this error and resolution as well.