TestProject Forum

Not able to select dropdown element

I tried all the ways to select item from this dropdown.Its not working
Kindly help.
I also tried bootstrap dropdown but please let me know how to use it also!
PFA
Dropdown|500x500

Hello @tanvi.lohakare
Did you try to do that:
In the recorder, save the element:

After that create a new action, and search for dropdown , select this action

In the element, select the element you saved with the select tag
And in the text field, enter Hungarian

If not, give it a try and tell me If it worked for you.

Will it work for non-select dropdown?
I am not able to select element .Kindly help
PFA

Try to use Select dropdown item found by text contents action
image
Let me know if you were able to do that.

i tried this.I am not able to find saved element in the list.
Kindly help

Kindly help to resolve this issue as majority of automation is blocked due to this error.

Hey,
I need to locate the full path of the element, selecting one of the values of the drop-down.


Please send me a screenshot like the above.

Hi there Tanvi,
This may or may not be helpful but one method I’ve found useful is to open object explorer (F12) and use the class + item text to locate the list item via XPath.
My syntax example is:
//*[contains(@class, ‘q-item__label’)][.=’{SiteName}’]
This method has worked for all drop down lists in my application (I only need to change the parameter value to match the list item).

My solution works really well in my circumstance but depends how things are structured from your end of course.
You may be able to use a similar or modified approach to achieve the result you want.
Good luck :slight_smile:

BTW, I have also tried using the “Web List Operations” add-on and it worked, but for some reason was a lot slower than my original solution.