Not able to run test

unknown error: unexpected command response
(Session info: chrome=103.0.5060.53)
Build info: version: ‘3.141.59’, revision: ‘e82be7d358’, time: ‘2018-11-14T08:17:03’
os.name: ‘Windows Server 2012 R2’, os.arch: ‘amd64’, os.version: ‘6.3’, java.version: ‘13.0.1’
Driver info: org.openqa.selenium.remote.RemoteWebDriver
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 103.0.5060.53, chrome: {chromedriverVersion: 102.0.5005.61 (0e59bcc00cc4…, userDataDir: C:\Users\kanake\AppData\Loc…}, goog:chromeOptions: {debuggerAddress: localhost:55289}, javascriptEnabled: true, networkConnectionEnabled: false, pageLoadStrategy: normal, platform: WINDOWS, platformName: WINDOWS, proxy: Proxy(), setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:extension:credBlob: true, webauthn:extension:largeBlob: true, webauthn:virtualAuthenticators: true, webdriver.remote.sessionid: 546cf8038be3d2499dd2549ecb1…}
Session ID: 546cf8038be3d2499dd2549ecb18306f
unknown error: unexpected command response
unknown error: unexpected command response

Using Test Project Agent 3.4.1

6 Likes

This is happening to me as well. It happens on the first step in the record view whenever I try to navigate to the URL to test.

Is there any way how to fix this issue in our end? Still got the same error here

There is no fix that I’m aware of.

Hello, i need help can anyone provide me please

I am also facing the same issue. As I launch the web recorder after it launches to the URL mentioned in the first step the browser closes unexpectedly. The error message received is the same as posted.

Path to check browser selenium drivers “%appdata%\TestProject\Agent\deps\drivers\Chrome”

chromedriver.exe is updating to chrome version 102. Even we replace with chrome versions 103, it is replacing again to chrome version 102 after we trying to execute any test. Thatsy not supporting for chrome version 103

I tried with chrome version 102. It is completely fine

same error for me …any solution yet ?

This has been happening for me as well. Always while in Record mode, obviously using Chrome. It would be nice if there were any responses to this. It’s making it impossible for me to get any work done.

I’ve been sporadically running into this issue as well. It might be related to this webdriver issue with the latest version of Chrome 4121 - chromedriver - WebDriver for Google Chrome - Monorail. The good news is that it looks like they are actively working in a solution.

I having the same issue. Is there around ?

Reposting this from another thread as it resolved it for me, bit of a hassle to need to do this but it works:

(Instructions for Windows, sorry I can’t provide Mac specific)

  1. Press Win + R and type ‘msconfig’
  2. Go to the Services tab
  3. Deselect both Google Update Services and apply
  4. Find an older version of Google Chrome. I found this site worked: Download older versions of Google Chrome for Windows, Linux and Mac
  5. Get the 64-Bit version 102.0.5005.63 and download
  6. Uninstall Google Chrome.
  7. Install the 102 version of Google Chrome

Automatic updates are now disabled so it will not update to 103 which is incompatible with TestProject, currently.
After performing these steps I was unblocked and able to run and edit tests again without issues.

2 Likes

Hello! what is the solution to this issue? This makes working with testproject impossible.

Now it is working for 103 chrome version also

I am try to write number in pin input field using type text or type text (using Adb). But it did not work . can anyone please help me regarding this . i am really thankful to all.