Navigate to URL - How to ignore "Your connection is not private"

So in one of my tests, I have a navigate to URL, but it gets stuck on this:


How do I get it to ignore? And is there a way to get it to ignore all certificate errors?

Hello @Chris.Rye
You can use the next article to avoid it:

Please let me know if you need more help.

Hello,
you can tell test project to skip certificate verifications if you set browser capabilities in a job flow.
I had that issue in the past, and that was the only way to make it work, certificate being invalid and Chrome browser not allowing without manual approval.
The trick is to use this capability structure in the job you setup:
{
“browserName”: “chrome”,
“version”: 91,
“goog:chromeOptions”: {
“args”: [
“–ignore-certificate-errors”
]
}
}

Hey !!
How can I add certificates in headless chrome for linux terminal ??

It’s a message from your browser that informs you that the connection is not secure. The most common cause of “Your connection is not private” is an incorrect date & time set on your PC. Chrome makes sure that your computer’s clock matches the clock in a Google server farm, and if it doesn’t, will block the connection to HTTPS sites for security reasons.

To fix your issue, set your computer’s clock to the correct current time.

  • Go to System Preferences
  • Choose Date & Time
  • Navigate to the Date & Time tab
  • Change the current time to the correct time (accurate to the nearest minute will do).

If it’s not your computer’s fault, it’s just a Chrome security feature. Chrome detects malicious activity going on with the site (like malware-laced ads, breach by hackers, etc.) and automatically warns you to protect you if it believes your security or safety might be at risk. If you want to override the warning, just hit Advanced → Continue to site.