Linux unable to view devices

My agent is registered but devices on my Debian server are never shown, while they are there. So I tried to reboot the adb server on my Debian server and it outputted the following:

displee@xyz:~$ adb reboot
displee@xyz:~$ 2022-06-09 12:46:01.703 [INFO ] i.t.a.m.f.l                              Android Virtual Device emulator-5554 disconnected
2022-06-09 12:46:01.772 [ERROR] i.t.a.b.a.d                              PUT https://api.testproject.io/api/v1/agent/devices/ZW11bGF0b3ItNTU1NA== - 400 (2qX7t3Os): Bad data was provided [Bad device data]
2022-06-09 12:46:02.704 [INFO ] i.t.a.m.f.l                              Android Device emulator-5554 connected
2022-06-09 12:46:08.133 [INFO ] i.t.a.m.f.l                              Queued device emulator-5554 information querying
2022-06-09 12:46:08.201 [INFO ] i.t.a.m.f.l                              Device emulator-5554 is still booting, waiting for it to fully load...
2022-06-09 12:46:13.180 [INFO ] i.t.a.m.f.l                              Device emulator-5554 is still booting, waiting for it to fully load...
2022-06-09 12:46:13.281 [INFO ] i.t.a.m.f.l                              Device emulator-5554 is still booting, waiting for it to fully load...
2022-06-09 12:46:18.430 [WARN ] i.t.a.m.f.l                              Device emulator-5554 already exists in list of connected devices
2022-06-09 12:46:18.430 [INFO ] i.t.a.m.f.v                              Checking if emulator-5554 has UIAutomator Server installed...
2022-06-09 12:46:18.443 [ERROR] i.t.a.b.a.d                              PUT https://api.testproject.io/api/v1/agent/devices/ZW11bGF0b3ItNTU1NA== - 400 (68qESRUd): Bad data was provided [Bad device data]
2022-06-09 12:46:18.444 [INFO ] i.t.a.m.f.v                              Checking if emulator-5554 has UIAutomator Server installed...
2022-06-09 12:46:19.748 [INFO ] i.t.a.m.f.v                              Device emulator-5554 has UiAutomator Server 2.0.0 installed
2022-06-09 12:46:19.748 [INFO ] i.t.a.m.f.v                              Getting new port for UIAutomator...
2022-06-09 12:46:19.749 [INFO ] i.t.a.a.a.c.a                            Attempting to create port forward on device emulator-5554 from 40105 to 6790...
2022-06-09 12:46:19.754 [INFO ] i.t.a.m.f.v                              Device emulator-5554 has UiAutomator Server 2.0.0 installed
2022-06-09 12:46:19.755 [INFO ] i.t.a.m.f.v                              Getting new port for UIAutomator...
2022-06-09 12:46:19.755 [INFO ] i.t.a.a.a.c.a                            Device adb forward finished successfully!
2022-06-09 12:46:19.755 [INFO ] i.t.a.a.a.c.a                            Attempting to create port forward on device emulator-5554 from 40923 to 6790...
2022-06-09 12:46:19.761 [INFO ] i.t.a.a.a.c.a                            Device adb forward finished successfully!
2022-06-09 12:46:20.032 [WARN ] i.t.a.m.f.l                              Device emulator-5554 already exists in list of connected devices
2022-06-09 12:46:20.032 [INFO ] i.t.a.m.f.v                              Checking if emulator-5554 has UIAutomator Server installed...
2022-06-09 12:46:20.437 [INFO ] i.t.a.m.f.v                              UIAutomator Server exited on emulator-5554
2022-06-09 12:46:21.356 [INFO ] i.t.a.m.f.v                              Device emulator-5554 has UiAutomator Server 2.0.0 installed
2022-06-09 12:46:21.356 [INFO ] i.t.a.m.f.v                              Getting new port for UIAutomator...
2022-06-09 12:46:21.357 [INFO ] i.t.a.a.a.c.a                            Attempting to create port forward on device emulator-5554 from 39827 to 6790...
2022-06-09 12:46:21.363 [INFO ] i.t.a.a.a.c.a                            Device adb forward finished successfully!
2022-06-09 12:46:21.820 [INFO ] i.t.a.m.f.v                              UIAutomator Server exited on emulator-5554

Apparently the device is not correctly being registered to Testproject? I tried lookin into the shell file to why this was happening but all the code is encrypted or something?

Apparently this fixed it self.

This topic was automatically closed after 180 days. New replies are no longer allowed.