Linux Agent not working

Hi,

As of a few days ago, my Lunux agent stopped working.
Triggering tests manually doesn’t even show the tests under Executions anymore.

Even though the status of the agent shows as ready.
I tried rebooting everything, reinstalling, etc. it still doesn’t seem to work.
Nothing has changed on my side. But I kept getting “Maintenance messages” while trying to log in for about two days, and then the agent stopped working.

Has anyone faced this issue? Please advise.

Thanks

Hey there :wave:

Have you tried removing the agent and re-registering it? That’s what usually does the trick for most of us when outages like these happen.

Hello i have the same problem. I also tried to register new agent, but after one execution i have the same behaviour. Did anybody solve this problem?

Hi there!

I have the same problem and Yes I have tried removing the agent and re-register it and it works for one day. The next day it is the same problem again :frowning: very tiresome and annoying.
Please help fixing the issue.

Is this the error message you are facing?
“Driver server process died prematurely.”

I also faced the same issue. Here is a link to my posts over the last few weeks. I will say though, that my agent has been working consistently on Linux for about 5 days straight now. I hope it stays this way.

Well, we are also facing this issue now :confused: Why, oh why!

Hello,
Just another update that my agent’s id.dat file disappeared again. I was hoping things were fixed as the linux agent stayed running for almost 4 days straight! A new record!..but needless to say, I was not shocked when it stopped working again and found that the id.dat file was deleted once again.

Is anyone else seeing this issue on linux machines?

Yes indeed, i noticed that when it stops working the id.dat file is missing. I thought i will try to create a backup of all the files of the agent and check if something is messed up once the agent fails again.

Thats what I’ve done…I have a backup file ready, and then I make a copy of it. Unfortunately, lately I need to do this daily since we cannot get a response from anyone on whether they will fix this or not.

Ah, so that works huh? Then i guess i will write a cron job to check if the file has been deleted or not and correspondingly place the file in the folder.

I was thinking the exact same thing.

Oh one thing to include in your cron job, is that after recreating the id.dat file, you will also need to stop all of the testproject processes and restart the agent.

1 Like

Can someone help me with this id.dat file please?
I even reinstalled the agent, but it still doesn’t seem to work.

thanks for the heads-up :metal: