TestProject Forum
Powered by leading experts in the test automation community

Keyboard search

is TP have addon for clicking search on keyboard

i tried with addOn press Enter and press AndroidKey with key SEARCH and also key ENTER
both is not working. any idea what should i do?

Hello @tri.putra.

You can try sending a key event to perform the search:
image

Is that the default keyboard on your device or another installed one?

i try key 66 (enter) and key 84 (search). its showing green (should be success), but its not actually click the search button in the keyboard (red circle).

for keyboard im not sure, im not change any input in keyboard. if i checked now i use gboard

Does pressing the button manually work in searching for the same scenario?
Is it possible to record a tap on the search icon in the textbox next to the text you’re typing in there?

Can you try tapping on one of the options in the list, and then performing the key event/enter?

yes pressing the android search keyboard button manually will close the keyboard and redirect me to page that show all the product with input text. (this is the expected scenario that i need to replicate using the recorder.)

search icon is not worked like enter it. its just symbols. (later i will ask dev team to make this symbols as enter button)
if try to tapping the option list it will redirect me to product it self. (while im looking for to redirect me to page that show all the product)