iOS device stopped working

Hello, I have been using iOS device without any problems until today. Does anybody know what has happened? Thanks.
Screenshot 2022-03-08 at 10.12.51

Hi @Miroslav ,

I want to clarify some details regarding this issue:

  1. Which iOS version is running on your device?

  2. Which agent version are you using?

  3. Did you try to connect another device, does it work?

  4. Did you upload the provisioning profile to TestProject, as it should be done?

  • iOS 14.8
  • using latest 3.5.0 agent version
  • I did not try another iOS device, just Android (works)
  • I did not upload the provisioning profile… should I?


Please follow this documentation:

It should be the case, let me know if you have managed.

Hello, new certificate is uploaded, but iOS device still not working…

Okay, are you getting any error messages?
If you do, please share a screenshot.

Just this
Screenshot 2022-03-08 at 10.12.51

Please try other iOS device.
These solutions should help:

  1. Please reinstall the agent and reproduce the issue.

  2. If the issue still persists, please quit the TestProject Agent and then clean the these folders:








also delete the following file:


You can find them here:


Open the Start menu, type %appdata%\TestProject\Agent\ and hit enter.



Open Files Finder and choose Go form the top menu, select Go to Folder and type:
~/Library/Application Support/TestProject/Agent

Navigate to ~/.testproject/agent/

Then start your agent again and let me know if that works.

It is already working.

Thank you a lot

@Miroslav @alex.ivanov when i run a job , Nothing happen nor latest reports are generates . Can you please help me regarding this .

I tried this but always shows for iOS

“Display device screen failed” Application error occurred during the request processing, please try again

This topic was automatically closed after 180 days. New replies are no longer allowed.