TestProject Forum

iOS 14.8.1 & 15.1 driver not compatible with TP Agent 3.3.0 [ON PROGRESS]

Hi All,
Just a quick warning that recent iOS update (14.8.1 and 15.1) Ive been unable to get TP agent to talk to iOS devices ( android still happily working).
Ive put in help request to TestProject but thought it would be worth warning others till a new TP agent >3.3.0 is release with a new driver

5 Likes

Hi @tsalisbury,
Thanks for sharing the information with the community, while it’s true that 15.1 is not supported at the moment, 14.8.1 should work, as we are supporting 12-15.
Please make sure there is no other issue like a provisioning profile, or an application that was not signed properly preventing you from starting your recording and execution.

@Amit.Lacher Im 100% is 14.8.1 update as device was working last night on 14.7.1 and device is still provisioned:



tried uninstalling TP app and connecting to both my windows and mac comps, can start the view device and on the device can see it reinstall the TP app but then fails to connect

When will the Support for iOS 15.1 be released?

@Amit.Lacher

2021-10-28 14:38:03.026 INFO  pool-3-thread-7 i.t.a.m.q                                iOS 14.8 image has been validated successfully
2021-10-28 14:39:38.088 INFO  qtp1699214800-1 i.t.a.w.b.c                              EventsSocket 259d4b43-6e84-48d2-9658-5abdc6a6d8d3 #1 disconnected: [1001] null
2021-10-28 14:39:38.200 INFO  EventThread     i.t.a.b.c.a                              User 202399 has disconnected
2021-10-28 14:39:42.354 INFO  EventThread     i.t.a.b.c.a                              User 202399 has connected
2021-10-28 14:39:42.371 INFO  qtp1699214800-6 i.t.a.w.b.c                              EventsSocket 0781d6da-817d-470d-a11f-ebc263456ee8 #1 connected
2021-10-28 14:39:45.020 INFO  qtp1699214800-1 i.t.a.w.b.f                              MirroringSocket 8d8f8dae-2627-4f0b-98df-787939560ec5 #2 connected
2021-10-28 14:39:45.172 INFO  pool-3-thread-8 i.t.a.b.a.d                              GET https://api.testproject.io/api/v1/agent/tokens?type=DeviceInteraction&token=iRM1U1yYlg3SgINxO41xc12PBl6Y3S0T4vOfwAGoZTI1 - 200 (cx5tHaZD): No Message
2021-10-28 14:39:45.173 INFO  pool-3-thread-8 i.t.a.b.b.c                              Token DeviceInteraction is valid
2021-10-28 14:39:45.175 INFO  qtp1699214800-1 i.t.a.w.r.e.DeviceInteractionEndpoints   Received request to set device orientation to PORTRAIT
2021-10-28 14:39:45.192 INFO  qtp1699214800-1 i.t.a.w.r.e.DeviceInteractionEndpoints   Received a request for device 00008030-000D143022EB802E screen mirroring
2021-10-28 14:39:45.657 INFO  qtp1699214800-1 i.t.a.i.n                                XCUITest is not running on 00008030-000D143022EB802E
2021-10-28 14:39:45.766 INFO  qtp1699214800-1 i.t.a.b.b.c                              Requesting driver: Appium_iOS (existing: 9558e326e511b57f0495ca12751c98882a951864826ff7c5e630acb6952114fe)
2021-10-28 14:39:45.857 INFO  qtp1699214800-1 i.t.a.b.a.d                              GET https://api.testproject.io/api/v1/agent/drivers?type=Appium_iOS&version=9558e326e511b57f0495ca12751c98882a951864826ff7c5e630acb6952114fe - 204 (qVDvBh2Q): Already up to date
2021-10-28 14:39:45.857 INFO  qtp1699214800-1 i.t.a.b.b.c                              Agent already has the latest Appium_iOS (9558e326e511b57f0495ca12751c98882a951864826ff7c5e630acb6952114fe) driver
2021-10-28 14:39:45.857 INFO  qtp1699214800-1 i.t.a.m.q                                Validates if iOS image version 14.8.1 is ready...
2021-10-28 14:39:46.062 INFO  qtp1699214800-1 i.t.a.b.a.d                              GET https://api.testproject.io/dependencies/ios-images/14.8 - 200 (CJez7kOp): No Message
2021-10-28 14:39:46.063 INFO  qtp1699214800-1 i.t.a.b.b.c                              Received link to download dependency
2021-10-28 14:39:46.063 INFO  qtp1699214800-1 i.t.a.b.b.k                              Downloading dependency...
2021-10-28 14:39:47.569 INFO  qtp1699214800-1 i.t.a.m.q                                iOS 14.8 image has been validated successfully
2021-10-28 14:39:48.047 INFO  pool-3-thread-8 i.t.a.i.n                                Executing XCUITest (WDA) on 00008030-000D143022EB802E
2021-10-28 14:39:49.998 INFO  pool-3-thread-8 i.t.a.i.n                                Found WDA installed of the same version 3.3.0 on the device, skipping uninstall
2021-10-28 14:39:49.998 INFO  pool-3-thread-8 i.t.a.i.n                                WDA is already installed on device.
2021-10-28 14:39:50.669 INFO  pool-3-thread-8 i.t.a.i.n                                Trying to start XCUITest on 00008030-000D143022EB802E...
2021-10-28 14:39:53.378 ERROR pool-3-thread-8 i.t.a.i.n                                XCUITest (WDA) failed to start
2021-10-28 14:39:53.378 INFO  pool-3-thread-8 i.t.a.i.n                                Failed attempt to start XCUITest on 00008030-000D143022EB802E, retrying...
2021-10-28 14:39:53.378 INFO  pool-3-thread-8 i.t.a.i.n                                Executing XCUITest (WDA) on 00008030-000D143022EB802E
2021-10-28 14:39:54.737 INFO  pool-3-thread-8 i.t.a.i.n                                Found WDA installed of the same version 3.3.0 on the device, skipping uninstall
2021-10-28 14:39:54.738 INFO  pool-3-thread-8 i.t.a.i.n                                WDA is already installed on device.
2021-10-28 14:39:55.352 INFO  pool-3-thread-8 i.t.a.i.n                                Trying to start XCUITest on 00008030-000D143022EB802E...
2021-10-28 14:39:57.828 ERROR pool-3-thread-8 i.t.a.i.n                                XCUITest (WDA) failed to start
2021-10-28 14:39:57.829 INFO  pool-3-thread-8 i.t.a.i.n                                Failed attempt to start XCUITest on 00008030-000D143022EB802E, retrying...
2021-10-28 14:39:57.829 INFO  pool-3-thread-8 i.t.a.i.n                                Executing XCUITest (WDA) on 00008030-000D143022EB802E
2021-10-28 14:39:59.171 INFO  pool-3-thread-8 i.t.a.i.n                                Found WDA installed of the same version 3.3.0 on the device, skipping uninstall
2021-10-28 14:39:59.171 INFO  pool-3-thread-8 i.t.a.i.n                                WDA is already installed on device.
2021-10-28 14:39:59.815 INFO  pool-3-thread-8 i.t.a.i.n                                Trying to start XCUITest on 00008030-000D143022EB802E...
2021-10-28 14:40:02.268 ERROR pool-3-thread-8 i.t.a.i.n                                XCUITest (WDA) failed to start
2021-10-28 14:40:02.268 INFO  pool-3-thread-8 i.t.a.i.n                                Failed attempt to start XCUITest on 00008030-000D143022EB802E, retrying...
2021-10-28 14:40:02.268 ERROR pool-3-thread-8 i.t.a.i.n                                Failed all attempts to start XCUITest on 00008030-000D143022EB802E
**2021-10-28 14:40:02.270 ERROR qtp1699214800-1 i.t.a.w.r.m.AppExceptionMapper           io.testproject.java.exceptions.AppException: Failed all attempts to start XCUITest on 00008030-000D143022EB802E**
2021-10-28 14:40:02.323 INFO  qtp1699214800-6 i.t.a.w.b.f                              MirroringSocket 8d8f8dae-2627-4f0b-98df-787939560ec5 #2 disconnected: [1005] null

Hi @tsalisbury @tsalisbury,
We are aware that there is an issue with 14.8.1, and 15.1 and our team is working on it,
When we will have an ETA I will share ASAP. please hold up while we are investigating the root cause of this issue.

1 Like

Just to say the two devices I had effected by this, I reflashed to iOS 15.0.2 while its still has a valid certificate and they are now working with automation. Not really a solution but meant my iOS tests are running again. Be aware if reading you only have 2 weeks after iOS releases a new iOS version to revert to older one before its no longer allowed to be installed

For those watching the feed took TP Agent 3.3.1 for spin with iOS 15.1 sadly still no joy, so stick with iOS 15.0.2

1 Like

Hi @tsalisbury,
The update to the agent is unrelated to the iOS issue, we are still working on it and will post it here once it’s resolved asap.

1 Like

Hi everyone,
I am happy to update you that we have discovered the root cause of the issue and we have found a potential fix. We are in the progress of implementing it and this issue should get resolved before the end of the month, we will try to make it even earlier than that.
The fix will not require you to update your agent and we will post here once it’s implemented.
Thanks for the patience.

1 Like

I hope it’ll also support iOS latest beta version such as the latest iOS 15.2 beta. All of my testings require the iOS to be in the beta developer version.

Hi everyone, @mhafiz.job , @tsalisbury @john.roquemore.
We have released the update and iOS 14.8.1 and 15.1 should work.
It should potentially fix the issue with 15.0.2, if that does not work please update to 15.1 and use that version instead.
Regarding 15.2 it’s still in beta and we will test that as well when released.
Our fix potentially supports it, but if it does it’s not officially supported yet.
Feel free to test that as well and let us know.

Feel free to reach out if you have any issues.
Happy testing :sunglasses:
Amit.

1 Like

I have just verified on my iPhone with 15.1 version and found it to be working.
You need to just remove the older agent from your iPhone and try running it again from Browser and it should work