I'm Getting the "Operation failed, please try again" Error when trying to record web test?

I’m Getting the “Operation failed, please try again” Error when trying to record web test?
Can you please check?

Agent version:3.5.0

image

3 Likes

Same error on several different Android Phones - first it hangs on “Making sure device is unlocked” - which it is. And then I get this error above.

Mirroring android/iOS devices (upper right corner where it shows connected devices) are working normally and I am able to connect and control devices.

Only Recording action shows this error.
Agent version. 3.5.0

Regards,
Rok

1 Like

Yes, same happens to me also

1 Like

fixed here [Error] Operation failed, Please try again in android device - #14 by CassiereJ

Now I’m facing the same issue
image

1 Like

The same problem. This error happens everyday

1 Like

Morning I can able to record the scripts but now I’m unable to do

I think the server got a problem. So just wait for the dev to solve it.

It was working for me yesterday but now I am experiencing this issue too

1 Like

@alex.ivanov @ran.ferdinaro i am getting same "operation failed "issue again . why this issue is not resolved yet . please do something for us .

Same here, looks like this problem occurs since updating the agent to 3.5.0

1 Like

Hi all,
Thank you for sharing this information.
I want to let you all know that our teams are working on it.
We know the last couple of days have caused you inconveniences and we want to let you know that we are really sorry for it.

3 Likes

indeed seems issue is back this morning (do not believe this is a 3.5.0 agent issue as tried 3.4.2 too)

2022-04-08 10:02:42.114 INFO  qtp164091409-61 i.t.a.w.b.c                              EventsSocket cbfe0690-9d90-4dcc-a709-43602baf5ba3 #5 connected
2022-04-08 10:03:29.938 ERROR pool-3-thread-8 i.t.a.f.l.a.I                            Failed to activate Recording state
javax.ws.rs.ProcessingException: java.net.SocketTimeoutException: Read timed out
	at org.glassfish.jersey.client.internal.HttpUrlConnector.apply(HttpUrlConnector.java:287)
	at org.glassfish.jersey.client.ClientRuntime.invoke(ClientRuntime.java:252)
	at org.glassfish.jersey.client.JerseyInvocation$1.call(JerseyInvocation.java:684)
	at org.glassfish.jersey.client.JerseyInvocation$1.call(JerseyInvocation.java:681)
	at org.glassfish.jersey.internal.Errors.process(Errors.java:315)
	at org.glassfish.jersey.internal.Errors.process(Errors.java:297)
	at org.glassfish.jersey.internal.Errors.process(Errors.java:228)
	at org.glassfish.jersey.process.internal.RequestScope.runInScope(RequestScope.java:444)
	at org.glassfish.jersey.client.JerseyInvocation.invoke(JerseyInvocation.java:681)
	at org.glassfish.jersey.client.JerseyInvocation$Builder.method(JerseyInvocation.java:411)
	at org.glassfish.jersey.client.JerseyInvocation$Builder.get(JerseyInvocation.java:311)
	at io.testproject.agent.b.b.a.e(TestProjectAgent:673)
	at io.testproject.agent.managers.recording.a.a(TestProjectAgent:30)
	at io.testproject.agent.managers.recording.d.a(TestProjectAgent:261)
	at io.testproject.agent.fsm.local.a.J.a(TestProjectAgent:226)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at io.testproject.agent.c.d.run(TestProjectAgent:33)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:830)
Caused by: java.net.SocketTimeoutException: Read timed out
	at java.base/sun.nio.ch.NioSocketImpl.timedRead(NioSocketImpl.java:284)
	at java.base/sun.nio.ch.NioSocketImpl.implRead(NioSocketImpl.java:310)
	at java.base/sun.nio.ch.NioSocketImpl.read(NioSocketImpl.java:351)
	at java.base/sun.nio.ch.NioSocketImpl$1.read(NioSocketImpl.java:802)
	at java.base/java.net.Socket$SocketInputStream.read(Socket.java:937)
	at java.base/sun.security.ssl.SSLSocketInputRecord.read(SSLSocketInputRecord.java:450)
	at java.base/sun.security.ssl.SSLSocketInputRecord.bytesInCompletePacket(SSLSocketInputRecord.java:68)
	at java.base/sun.security.ssl.SSLSocketImpl.readApplicationRecord(SSLSocketImpl.java:1409)
	at java.base/sun.security.ssl.SSLSocketImpl$AppInputStream.read(SSLSocketImpl.java:1022)
	at java.base/java.io.BufferedInputStream.fill(BufferedInputStream.java:245)
	at java.base/java.io.BufferedInputStream.read1(BufferedInputStream.java:285)
	at java.base/java.io.BufferedInputStream.read(BufferedInputStream.java:344)
	at java.base/sun.net.www.http.HttpClient.parseHTTPHeader(HttpClient.java:746)
	at java.base/sun.net.www.http.HttpClient.parseHTTP(HttpClient.java:689)
	at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1610)
	at java.base/sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1515)
	at java.base/java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:527)
	at java.base/sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:308)
	at org.glassfish.jersey.client.internal.HttpUrlConnector._apply(HttpUrlConnector.java:399)
	at org.glassfish.jersey.client.internal.HttpUrlConnector.apply(HttpUrlConnector.java:285)
	... 20 common frames omitted
2022-04-08 10:03:29.940 ERROR qtp164091409-65 i.t.a.w.r.m.AppExceptionMapper           io.testproject.java.exceptions.AppException: Application error occurred during the request processing, please try again
2022-04-08 10:03:29.983 INFO  qtp164091409-64 i.t.a.w.b.c                              RecorderSocket d623b1b1-27b7-4802-869b-8c03655f5688 #5 disconnected: [1005] null
2022-04-08 10:03:29.984 INFO  qtp164091409-11 i.t.a.w.b.c                              MobileFramesSocket e9f449e1-10e3-45ea-a093-51f6b9ccc0a9 #4 disconnected: [1005] null
2022-04-08 10:03:29.984 INFO  qtp164091409-11 i.t.a.w.b.c                              Last device mirroring client disconnected
2022-04-08 10:03:30.074 INFO  state-machine   i.t.a.m.f.t                              Stopping Screen Mirroring...
2022-04-08 10:03:30.074 INFO  state-machine   i.t.a.m.f.t                              Stopping Scrcpy Android mirroring...
2022-04-08 10:03:30.074 INFO  state-machine   aa                                       Disconnecting from server...
2022-04-08 10:03:30.136 INFO  grpc-default-ex aa                                       Heartbeat stopped.
2022-04-08 10:03:30.137 INFO  state-machine   aa                                       Channel Disconnected.
2022-04-08 10:03:30.137 INFO  state-machine   aa                                       Client shutting down...
2022-04-08 10:03:30.141 INFO  state-machine   aa                                       Client has been shut down.
2022-04-08 10:03:30.142 INFO  state-machine   i.t.a.m.f.t                              Scrcpy stopped.
2022-04-08 10:03:30.142 INFO  state-machine   i.t.a.f.l.a.I                            Ending recording mode...
2022-04-08 10:03:30.161 INFO  pool-3-thread-6 i.t.a.b.b.a                              Reporting state: Idle

@ran.ferdinaro can you please tell how much time it took today to get back in normal condition?

Don’t think so, I have tried with two different versions of the agent and the issue is reproducible on both

Since last week and even today we are also experiencing same – test recorder is not working and whole test project is very slow

My investigation from the last week is:
I’m working from 9 am to 6 pm (UTC +3:00), so for me it’s not working from 9 to 3pm, but from 3 pm and till the end of my work day (6pm) it’s working well.

How long will it take to solve this problem

yes but today in this time it does not work for me . Did it work for you ? @Artest

yes, it hasn’t worked today at all :frowning: @hur_2