I am not able to use the IOS device even the setup is Done

I am getting error present in the screenshot when i try to select IOS Device

Hello @vinaynalla, Thank you for reaching out.
In order to use iOS devices with TestProject, you must first provision them.

Please check that you made your provisioning profile and set your iOS account settings correctly according to the following guide.

The provisioning profile should be a Wildcard.*
Also the certificate and profile type should be only for iOS App Development and not any other.​

  • I have modified the photo you sent to hide the device’s SEID


first it was successfully connected to my TestProject But when my Iphone is updated i am getting this Error I did the same process again then also i am getting same error

Hi,

i am facing the same issues with my devices.
Is iOS 15.3 supported?

Same problem here, looks like TestProject is not currently supporting iOS 15.3.

I’d got 2 iPhones working with TestProject (provisioned).
Then updated one of them to iOS 15.3 cause of vulnerability warning. This device didn’t work with testproject anymore. Also, TestProject app installed in iPhone updated disapeared.

Tried updating testproject Agent from v3.3.0 to v3.4.2. Then started getting this message:
testproject error
I had Apple Mobile Device Service running, but tried installing iTunes anyway. It didnt help.
Next I’ll try is rollback to 15.2.1.

Hi @dominik-b.reuter @amurciano ,

Currently, 15.3 is not supported.
Please try on 15.1 or 15.2 they should work well.
Let me know if you managed.

Hi @vinaynalla ,
Which iOS version do you have installed on your device?

Hey Alex,

iOS 15.1, 15.2 or 15.2.1 are working yes but we have to test iOS 15.3 with Applications and this isnt working.

Hi @dominik-b.reuter ,

We currently do not support iOS 15.3.
We are working on it, and it will come out soon.

Hi @dominik-b.reuter @vinaynalla @amurciano ,

We have updated iOS 15.3.
It should work well.
Let me know if you experience any issues with the 15.3 version.

iPhone 8 with iOS 15.3 working again using v3.4.2 agent (no update).
Thanks @alex.ivanov

Hey Alex,

yes it works now :+1:t2:

Many thanks

@dominik-b.reuter @amurciano You are welcome :slight_smile:

Hey! It doesn’t work with IOS 15.4?

Hi @naggarwal,
We support up to 15.3 at the moment. Please downgrade and try again.

okay thankyou so much!

Anytime @naggarwal :slight_smile:
Feel free to contact us if you have other questions.