How can I remove an agent which have 'Executing' state?

My agent states ‘Executing’ and not allows to delete. Please share your idea that helps. Thanks in advance.

Rabby Shaikh

Executing state

U performed the Job operation? Try to reassign agent in ur jobs

Thank you.

I reassign the agent to a job and run it but nothing happens.

Hmmm and in the Monitors interface ur job is not displayed ? When u run this one

Yes exactly.

I just need to remove that agent, please help to do that

Open Agents interface → Click on ur agent → Click Executions tab and click on Abort or Cancel button (i don’t remember name of button). Or delete ur agent in the Agent interface and register a new one

Thanks for the reply.

I do not find Abort or Cancel button but I did remove few jobs that available here.

image

Also tried to deleted the Agent after that but unable to do that, it says “Agent is currently executing, cannot delete…” :frowning_face:

image

Hmmm very strange… u closed the agent in tray? And try to close in task manager

I did uninstall the agent from my PC but still not able delete from WEB account.

Quit the TestProject Agent and then clean these folders:
coded-tests, data-sources, addons, apps, executions, logs, temp, workers-executions
Also, delete the following file: lock
You can find them here:
Windows
Open the Start menu, type %appdata%\TestProject\Agent\ and hit enter.

Then restart the agent .

Already did that too but still same issue, thanks anyway.

Anyone can solve this issue or how can I contact the tech support from TestProject.io? anyone knows??

Hmmm try to one more solution. Create a new account and try register a new agent. If not helped, then try to unregister agent in tray and register new one

I can create another agent successfully but I need to delete that agent which status is ‘Executing’.

And after create a new one, can u run ur test/job after that? Or due to old agent u can’t do it?

Yes I did run a job and it worked with the newly added agent but can’t delete the ‘Executing’ agent still.

Forget about agent =) The most important thing is that it works

Yeah thanks. I just worried about any complex scenario create further regarding this executing agent. :slight_smile:

I had a same problem with my Azure K8 agent, I deleted and restarted agent in K8, then status of agent in TestProject dashboard changed to disconnected. So, you have to “kill” your agent outside of TestProject since it is locked. In my case it was Kubernetes agent that got hanging, if you have local agent, you have to find in your processes the process that hangs and kill it.