TestProject Forum

GLIBCXX_3.4.21 not found when launching TestProject on CentOS 7

I Installed the latest 0.65 Testproject agent on a CentOS 7 VM. I chose y at the end of the installation as well.

I ran the following command to start Testproject as per this document: Installation and Setup - TestProject Documentation
and I got the following error:

$ ./TestProjectAgent
./TestProjectAgent: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21’ not found (required by ./TestProjectAgent)

CentOS Version: CentOS Linux release 7.9.2009 (Core)
GNOME Version: 3.28.2
YUM version: $ yum --version
3.4.3
Installed: rpm-4.11.3-45.el7.x86_64 at 2020-11-30 19:03
Installed: yum-3.4.3-168.el7.centos.noarch at 2020-11-30 19:03
Installed: yum-plugin-fastestmirror-1.1.31-54.el7_8.noarch at 2020-05-26 17:13

If I launch it using the java -jar io.testproject.agent.launcher.jar command, I get the following issue:

image

[EDIT:] There was no issue with the internet connection, just to be clear.

The registration worked after running the following:

nohup ./jre/bin/java -jar io.testproject.agent.launcher.jar &

great to hear, you can find article on this matter here Launching the TestProject agent on CentOS 6 | TestProject Help Center

1 Like