TestProject Forum
Powered by leading experts in the test automation community

Getting this error when trying to run generated code through Eclipse/IntelliJ

java.lang.UnsupportedClassVersionError: io/testproject/proxy/addon/io/testproject/addon/clickactions/ClickIfVisibleAndroid has been compiled by a more recent version of the Java Runtime (class file version 57.0), this version of the Java Runtime only recognizes class file versions up to 52.0

Hi @neehal,

You are getting this message because you are using an older version of Java.
To solve this issue, you can update to openJDK 13.

Another possible ways to solve it can be found here: https://stackoverflow.com/questions/47457105/class-has-been-compiled-by-a-more-recent-version-of-the-java-environment

Let me know if you were able to solve it :slight_smile:
Amit

Thanks @amit.yahav, its working fine now

That’s great @neehal!
Glad that I could help you :slight_smile: