TestProject Forum

Error while sending email using add-on "SendEmail" by Test project

I am getting below error, while sending an email.

java.security.AccessControlException: access denied (“java.lang.RuntimePermission” “setContextClassLoader”)

Note : I was able to send an email for first few times, but later it was not working and giving above error.

I do experience the same error and I have never been able to send a mail succesfully. (also not with the picksmart addon)

It seems not to matter what I am filling in. I tried a non existing hosts to see if i would get an error like: unable to connect / host not found. But I always seem to get the same acces denied error.

I tried both a gmail account as a personal smtp host.

Any suggestions on how to debug or solve the issue, is greatly appreciated :slight_smile:

I solved the issue: What did i do

Testing if your step “send email” is working while in record mode isn’t possible. In record mode it will always give the ‘access denied error’

If you run an actual test the error is more helpfull. For a gmail account I had to enable ‘insecure app acces’ before it worked.

see here: Less secure apps & your Google Account - Google Account Help