TestProject Forum
Powered by leading experts in the test automation community

Error conecting with iOS devices

The last two weeks the connection with the iOS devices rarely works correctly more than 6 hours. They appear connected, but when I try to open a session (from the web or from the sdk) it shows different error messages: “maximum amount of attempts (3) reached”, “Requested device was not found”, but the devices appear as connected .
The agent version is 0.62.17, I have tried with previous versions (until 0.62.11) but I don’t see any changes in the behavior.
Devices have iOS 13.4.1 (I have not made any updates)
Here you have a link to the logs to see if you can help me:

Hello @carmelo.gascon
What iOS devices are you using?
Do you have another machine to try on and see if the issue appears there as well?

Hi @ran.tzur,
I’m using iPhone 8 and iPhone XR
I have tried it on three different machines with 4 different devices and the behavior is the same.


Hi @carmelo.gascon,

We’ve released Agent 0.63.2 with many fixes geared towards stabilization for iOS.
Could you please update your Agent and check if it fixes the issue you described above?


Hi @marat,
I’ll do it, thank you. I think that when there are several terminals, the agent does not manage it properly, could it be?

There can be only one Agent instance running at a time.
When saying several terminals you mean just several shells open? If so, this shouldn’t be an issue.

Hi @marat,

I’ve one computer with 2 devices connected (one test running at a time), and there aren’t any problems.
I’ve two computers with 3/4 devices connected (one test running at a time), and here is where the problems are occurring.
I am lowering the number of terminals per computer to verify if the incidence goes this way.

As mentioned earlier I doubt that amount of terminals open might have any affect.
On the other hand, Agent 0.63.2 has fixes for cases when working with multiple devices is not functioning properly, and should help in the situation you’ve described.