"Display Device Screen Failed" Error Across Many Android Devices

Steps That Led To Error:

  • I opened a new test, and decided to create new parameters while the device initiated.
  • Creating the new parameters was very slow, and I ended up accidentally creating multiples.
  • One parameter didn’t get created.
  • I noticed that the device finished initiating, and added a single test step to the test.
  • I had to leave the test in a hurry, and disconnected the device.
  • When I returned to my PC and tried to reconnect, I got this error:

testproject_error

Troubleshooting Steps I Have Performed:

  • Restarted PC
  • Disconnected/Reconnected Android device
  • Uninstalled “Appium Settings” from Android device and allowed TestAgent to reinstall it.
  • Reinstalled TestAgent
  • Unregistered my PC from TestAgent, unregistered my Android device, then uninstalled TestAgent, restarted both PC and Android device and tried making everything again from scratch
  • Uninstalled TestAgent and cleared everything from “C:\Program Files\TestProject Agent” as well as “C:\Users{username}\AppData\Roaming\TestProject”
  • Checked adb.exe was present
  • Reinstalled “io.appium.uiautomator2.server” and “io.appium.uiautomator2.server.test” on Android device
  • Tried connected three different Android devices to the agent, none worked.
  • Uninstalled both TestAgent and Chrome (including clearing out “C:\Users{username}\AppData\Local\Google\Chrome”)
  • Tried enabling all permissions on “io.appium.uiautomater2.server”
  • Tried deleting “id.dat” and “lock” from “C:\Users{username}\AppData\Roaming\TestProject\Agent” specifically
  • Tried running TestProject from Firefox

What I’ve Narrowed Down:

  • This issue is exclusive to my PC (it works on someone else’s PC/Agent, and does not work when I register a new agent to my PC).
  • This issue is cross-device (I’ve tried three Android devices).
  • This issue is exclusive to the device screen sharing (my tests and jobs will still run, but I cannot record new tests).

I’ve already sent an email to support, but I’m also posting here in case anyone has ran into this issue.

Can I get a response to this? I’ve been fighting this error for a week now, and it’s beginning to spread to other PC’s and users when my profile gets logged in on their computer.

I still don’t know what the issue is, but it turns out that it’s narrowed down to my specific TestProject account. Creating a new account solved the issue. Going to try deleting and recreating the original account with the bug and see if that fixes it for that specific account.