Display device screen failed at all tries

Hello,
I can’t use the recorder on Android Emulator anymore.
I always get “Display device screen failed” with “Failed to start mirroring, please contact support”.
Could you please help me ?

Hi @cpopiol-ext,
What is your agent version?
What is your OS version?
What is the emulated device version?

There are a few Android-related things that you should do:

  1. Enable “Developer options”.
    This could be done by entering “Settings” → “About Phone” → repeatedly tapping the “Build number”.
    You should get a message that says your enabled developer options.

  2. Inside “Developer options”, enable: “Stay Awake”, “USB debugging”, “Disable Permissions Monitoring” (if it’s available).

  3. Under “Select USB configuration” select “MTP” or “File transfer”.

  4. Scroll down and turn the animation off for: “Window animation scale”, “Transition animation scale”, “Animator duration scale”.

  5. When you plug the USB cable to your Android device, you will be asked 2 things:
    Allow access to device data → select “YES”
    Allow USB debugging → select “OK”

These documents might help as well:

Let me know if any of the solutions works for you.

Hello !
Thanks for your reply.
I’m on a mac M1, using agent 3.5.0 then 3.4.2 (as this one worked before).
For the emulator : Pixel4, on API 29 (Android 10)
I did all the things asked (except part 5, as I don’t plug any usb cable, it’s an emulator)
No changes

Please quit the TestProject Agent and then clean these folders:

coded-tests, data-sources, addons, apps, executions, logs, temp, workers-executions

also, delete the following file: lock

You can find them here:

Windows
Open the Start menu, type %appdata%\TestProject\Agent\ and hit enter.

macOS
Open Files Finder and choose Go from the top menu, select Go to Folder and type: ~/Library/Application Support/TestProject/Agent

Linux
Navigate to ~/.testproject/agent/

Then, please do the following:

  1. Restart your Agent
  2. Reproduce the issue you encountered
  3. Send us the agent logs of today for analysis to support@testproject.io.

You can download the logs and upload them here as shown below:

Thanks for your support !
I tried, but issue is still there.
I will send the log by email

Thanks for your support, logs sent to support@testproject.io