TestProject Forum

Device is not getting detected

Please help me to find out why I am not able to record and view the device.

I am not able to record the device app.
I tried all the things which are present on
https://intercom.help/testprojectio/en/articles/3537809-failed-to-connect-android-device

hiya @Sangita,
What device are you attempting to connect, I found recently i have to go into developer option on android device and ensure “Allow ADB debugging in charge only mode” then when device is connected ensure its in charge only.

Some phones get abit weird with other modes and find just using above meant from pixel to infinix devices played happily

1 Like

Hi,

I am trying to connect to a Samsung tablet but no luck.

I have tried with the emulator as well, facing the same issue. Could you please help me to figure out what would be the cause of the issue?

Bear with me im not TP support, just fellow automation engineer that had some of these issues along the way.
Have you tried a different usb cable / port?
Do you have multiple instances of adb on the machine running the TP agent?
When you connect the device on usb settings to you set to midi option?.
Under developer options have you got following enabled:
USB debugging
Allow ADB debugging in charge only mode

With last option have you tried with device connected have you on android device changed the usb to charge only and see if TP will talk to the phone?

1 Like

Hi @Sangita,
Please share with us the exact model and OS version of the device and the emulator API and name that you have tried to use.

Meanwhile, you can follow this article in order to rule out other common issues that are related to devices settings:

Also, you started by saying you follow the ADB guide? does ADB recognize your device when using the
adb devices command?

I would also check these articles to rule out other settings:

  1. Huawei Extra permissions
  2. realMe Extra permissions

Thank you @tsalisbury for being such a great help to the community, contributing, and sharing from your experience working with TestProject - much appreciated :slight_smile:

Thanks, @Amit.Lacher!

I am trying with a Samsung tablet with Android version 10.

Samsung Galaxy Tab A 8.0, Wi-Fi + 4G Tablet, 20.31 cm (8 inch), 2GB RAM, 32GB ROM