CSV data with table

Hi,
I want to use data source with table not comma so I import csv data source to excel file and I saved it one time as CSV UTF-8 And other time as CSV ( comma delimited) but still I got in TP failed to retrieve Data source .
can you help me please?

Hello @Aze49 .

Let’s follow the following example to upload a data source. Is a simple way to change values in parameters.

  1. Once you create the test you can download the data source template and put all the URLs there:

  1. Now you can fill the requested values to your source

**** Please check that each parameter that was named as input parameter written exactly as you named it inside the test.**

**** We recommend not to create by yourself the CSV template. And download it like in step 1.**

  1. Then upload to the Data Sources:

Go To Data Source → Click on + New Data Source → Drop your update CSV → Click on Creat

  1. Congrats now You can use it both in the tests and in jobs as well.

For test :

Click on the play button on your request test

Then after few steps you will reach out to “Run Web test XXX” click on your requested data Source

After you choose your Data Source click on Run

Now your test will run with the data source you have chosen.

For Job :

Click on the Data Source button on your request job

Same as well here choose your requested data source from the list and click on Update

Now your job is updated with the data source you choose. Once you will run it, the data source will run with the job.

You can see here video how to do that as well:

1 Like

Hi Ricardo,
Thank you for answering but all these steps I know them perfectly , the problem is when I import csv data source to excel file ( to change as table format) and I saved as CSV ( comma delimited) .
When I execute test case with file changed, I got failed to retrieve Data source message.

Hi @Aze49 .

I understand what you did and I tried to reproduce it.

It seems to me that you are getting this error because the file you are uploading doesn’t have column names - or the column names don’t match the parameter names.

Please check this and let me know.

Kind regards,
Ricardo.

Hi Recardo,
The importation file is doing correct, and column names are matching with the parameter names, because I don’t have problem if I use csv file without importation and I am using simple test case with just two parameters.

Thank you for help
Azedine

Hi @Aze49 .

Can you please send us the CSV file you are uploading?

You can send us here if you prefer:
image

Thanks,
Ricardo.

Hi Ricardo,
Sorry I got a blocking message when I try to send you CSV file :

After saving the file as CSV ( comma delimited) and when I opened with bloc not, separation data is with semicolon and not comma.
Is it something to do with excel before save the file ?

Thank you
Azedine

It has something to do with your international settings. Change th language settings in windows or change the seperator in Testproject.
In Testproject: edit the datasource and select ‘CSV Advanced’. Then change the separator in ‘semi-colon’. Always wondered why this field is hidden behind a button as there is only 1 advanced option.
Succes!

1 Like

Hi @Aze49 .

If you are still facing this issue, please contact us in the chat and we will schedule a meeting to solve it.

Regards,
Ricardo.

Hi Ricardo,
Now it’s ok, just if we edit data in csv file we have to save changed in excel form then we open again with csv, it’s little long process. but so far is correct.

Thanks
Azedine

@Aze49 Great.
Feel free to let us know if you need any help :slight_smile:

Thanks, its work for me :smiley: