TestProject Forum

Click "Record"- Error "Operation failed" [SOLVED]

Click on “Record” failed saying “Error - Operation failed”- Please try again.

When i checked the agents logs “following is shown”
Received link to download dependency
2020-07-16 09:33:58.588 INFO 20008 pool-3-thread-1 i.t.a.a.b.k Downloading dependency…
2020-07-16 09:34:02.715 ERROR 20008 pool-3-thread-1 i.t.a.a.a.c GET https://storage-euw1-files.testproject.io/extensions/1.0?X-Amz-Expires=604800&X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAITRD2MKKMDIUNQRA%2F20200715%2Feu-west-1%2Fs3%2Faws4_request&X-Amz-Date=20200715T233358Z&X-Amz-SignedHeaders=host&X-Amz-Signature=07c59f91f2dc1beebdcc86c1261eea616da4d2bcae07a1f0c6b0b70491d5c4ed - 403 (null): null
2020-07-16 09:34:02.717 ERROR 20008 pool-3-thread-1 i.t.a.a.b.k Failed downloading dependency [403]
2020-07-16 09:34:02.718 ERROR 20008 pool-3-thread-1 i.t.a.m.o Download of recorder extension version 1.0 failed
2020-07-16 09:34:02.720 ERROR 20008 pool-3-thread-1 i.t.a.d.a.H Failed to activate Recording state
java.lang.Exception: Recorder extension is not ready.
at io.testproject.agent.managers.recording.f.h(TestProjectAgent:71)
at io.testproject.agent.d.a.I.a(TestProjectAgent:178)
at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
at io.testproject.agent.b.b.run(TestProjectAgent:33)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
at java.base/java.lang.Thread.run(Thread.java:830)
2020-07-16 09:34:02.725 INFO 20008 state-machine i.t.a.d.a.H Ending recording mode…
2020-07-16 09:34:02.726 ERROR 20008 qtp920728858-10 i.t.a.w.r.m.AppExceptionMapper io.testproject.java.exceptions.AppException: Application error occurred during the request processing, please try again
2020-07-16 09:34:02.751 INFO 20008 idle-entry i.t.a.d.a.A Account plan: Free
2020-07-16 09:34:02.753 INFO 20008 idle-entry i.t.a.a Heartbeat State: Idle
2020-07-16 09:34:06.060 INFO 20008 jersey-client-a i.t.a.a.a.d PUT https://api.testproject.io/api/v1/agent/state - 200 (CrvtC9Jm): null

Hello @vnair.

Please contact us in the support chat so we can troubleshoot why the recorder Chrome extension failed to download.

Hi @david.goichman,
I am already in touch with support team.
Support team asked me to whitelist "domain io.testproject.* " . My IT team has whitelisted.
Still getting the same error.

I have the same issue when clicking Record.
It returns this error in dev mode.

Can you please help?image

Hey guys, I had this issue this morning as well but after I updated the agent and restarted my Mac it started to work again (my mac also updated to 11.5.1). Hope that helps

1 Like

It works to me now. Thanks.

The above issue was fixed let us know incase you encounter any problem.

1 Like