Chrome: The Selenium driver that exists in the TestProject Agent folder is missing, or outdated and incompatible

Have been using TestProject to manage my tests all day successfully. All of a sudden, I am receiving the following error when trying to load any of my tests.

I have tried unregistering and re-registering my Agent, restarting completely, and even looked at the Manual Driver update page as suggested (even though it’s for OFFLINE mode) and nothing seems to work. My current chrome version says its ‘105.0.5195.52’ on both my computer and the agent.

Screen Shot 2022-08-30 at 3.10.58 PM

However, the chrome Webdriver website doesn’t have any manual downloads for that version.

I now cannot edit, record or run any of my existing tests and I don’t see how I’d be able to update this manually. Anyone having the same issue or have any tips?

Thanks.

1 Like

hi
i’m getting the same issue
I am pretty sure it not from us but from them, so anything we do won’t help

1 Like

I have just uninstalled the latest version of the Chrome browser. I installed Chrome version 103 and disconnected the update services. I restarted my computer and TestProject is working fine. I can record tests as well as execute them.
In TestAgent’s logs, you can read that it uses chromedriver version 103.

I see my agent is not using the correct and latest chrome driver


image

Although I deleted folder 105.0.5195.54 many times, it reinstates to this folder when I start running tests.
Now I can’t record or run any tests because of this pop up

1 Like

Ahh… thanks for the update. I figured I’d have to revert versions. Just annoying. I know they aren’t providing ‘support’ TestProject anymore so that may be my only option. If this becomes a common occurrence, I just don’t see this being a long-term solution. :confused: sucks after putting so much time into tests to have some sort of outage like this happen almost every other day.

Update: I also followed all the steps of updating drivers and trying to run in Offline mode and I still get the same errors.

1 Like

U can downgrade to 104v chrome and will be nice. Maybe TP team will add this 105v web driver for support. Need to check after a few days

2 Likes

Hi Guys

I Removed Chrome from my MacBook

And install version 103 from Site: Download Google Chrome 103.0.5060.134 for Mac | Uptodown.com

And Work my jobs

But only Mac Os. (I not tested in Windows)

Link for Windows: Download Google Chrome 103.0.5060.134 for Windows | Uptodown.com

1 Like

same issue on windows

Do we have a solution or i have to downgrade the chrome?

1 Like

I´m using 104, and it´s working fine till now.

image

I am too facing the same issue

Gotta love all this stability they’re maintaining.

I hope TestProject will fix the issue with the Chrome. I tried all latest installed browsers in addition to Chrome such as: FireFOx and Edge.
Same issue with the “Error” message on orange background.

I have never had this issue until today and it is now occurring to all the users under this account, even thought the drivers are up to date

Hi Sir,

I have a one query regarding Test Project.

I wants to run my Selenium Scripts which I was scripted in Eclipse using Java.

Now, I wants to import and run those scripts into Test Project.

Is this possible. If Yes, Please suggest.

1 Like

after the last maintenance, TP started working again with Chrome 105!

1 Like