Cannot Type in OTP


Hi! I’m creating a test and having a problem when trying to type in the OTP by clicking the keyboards below. The Keyboard is perceived as a single object “ANDROID.WIDGET.LINEARLAYOUT1” as seen in the attached image and would not fill in any number in my OTP slot when I press the keyboard. The goal is just to add a certain OTP (2222 to be exact) with any means, can be typing in as well. How could I tackle this? Thank you!

Hi @SupawisT ,

For scenarios like this, I would suggest using the addon “tap at relative point”.
You can find and install the addon here:

Let me know if it helped.

@alex.ivanov Thank you for your support! It still doesn’t work yet since the element is considered as one with the frame (as in image) and I don’t know how to locate the button “2” using the addon you suggested. If possible, could you show me how it’s done?

@Wilho

You have to provide the Horizontal tap percentage and the Vertical tap percentage (notice: it starts from the top-left corner of the element) you will be able to tap on a specific point on the wrapper element.
Meaning, if you set both the values to 50, the tap will be on the center of the element.
Here you can read more about it and find an example:

@alex.ivanov It worked! Thanks!

@SupawisT Your welcome :slight_smile: