TestProject Forum

Cannot run Android tests on a real device with the new 3.0.0 agent release

After updating the agent to 3.0.0, I am not able to run the tests on a android real device with OS version 7.0. I am getting the below error.

Failed to execute request p8waM2ZlR06dwlraa98joQ_1: java.lang.NullPointerException

I tried running on a android emulator with OS version 11.0 and it runs fine.

Can someone help me with this?

@tofiqmaredia

Please send us your Agent logs via Intercom for examination.

Hi, any update for this case? I have the same problem with real device both OS 7 and 8. Once I downgraded it back into 2.3.7, it works well…

Rolled back to 2.3.7,

Did not encounter any issues with iOS only Android. Can you try to delete the TestProject agent on the device and force it to install again.

We are on it and will provide an update ASAP.
Until then, please revet to Agent 2.x version.

hi, still not working properly with 3.0.2, tested with real device OS 7 and OS 8. Then, back again to 2.3.7 and all good.
found this: Failed to execute request PhcSHytYiUKCJXDeswLOmg_1: java.util.concurrent.ExecutionException: java.lang.NullPointerException

let me know if I missed something…
thank you

I experience the same with 3.0.0 , I connected an Android real device, could record and run succesfully from the recorder , but when attempt to run from Project , the device didn’t react at all.
Moving to 3.0.2 splved the issue !!! Thanks
Device: samsung-sm_g950f Android ver 9

Hello,

The above error has been fixed on the agents latest version

you can download the latest version here: TestProject

let us know if you have any issues

1 Like