Cannot register agent and creating new agent gives "Agent is not running"

I tried searching other posts for answers but couldn’t find any to my problem.

I have been running TestProject agent for a year now, and now

  1. The agent that was once registed says Agent is not authorized
    → I deleted the agent from TestProject and uninstalled the agent
  2. I downloaded the latest agent and when I’m trying to register it:
    Agent is not running.
    Please start it and make sure it appears in your system tray.Once it’s running, retry registering it using the button below.

The agent is very much running and its running with admin privileges. I can’t find a solution for this one. Any tips?

1 Like

I solved the issue by:

  1. Uninstall the agent and clear all data when prompted
  2. Going to the download page TestProject
  3. Install older version of the agent from the bottom of the page: Version 3.4.0 for Windows

So the older version finally registered the agent. I still can’t register with newest version.